Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-01-2013, 11:27 AM   #1
Veteran Member
derelict's Avatar

Join Date: Jul 2011
Location: NoVa
Posts: 371
K7 Shutter timing in M

I just got a K7 and started playing with it but am having trouble in M mode. I am used to my ist DS where I can control everything and am learning the differences now. Here is my issue. I set the iso, I set the aperture, and then I go to the front wheel and attempt to dial in the shutter timing but it seems to fight me. I can decrease the shutter timing with no issues at all. When I go to decrease it though, it will not smoothly do it. Is there some setting somewhere that is fighting me (like it is auto meter is telling me not to)? It is really quite annoying. I can hit the green button and have it meter and set the shutter and aperture for me but under or over is hard to adjust. Here is a quick video. You can see how it jumps around and you can hear it clicking as I try to make it adjust but it seems to refuse to smoothly increase shutter timing.




Another question: can I dial in a custom shutter speed? Say, if I am light writing and want to start to shutter timing with my remote and end it with my remote?

09-01-2013, 11:46 AM   #2
Veteran Member




Join Date: Jul 2009
Location: London
Posts: 859
Unfortunately the answer might be in 'I just got a K7...' which points to if being second-hand.

Do you know its history? Could be a fault with the front e-dial.

How does it operate in other modes that involve the front e-dial, i.e. when switching between images in playback mode?
09-01-2013, 11:51 AM   #3
Veteran Member
derelict's Avatar

Join Date: Jul 2011
Location: NoVa
Posts: 371
Original Poster
Very low shutter count, around 4k, and it great condition. Not a single issue with anything else. There are no issues with the dial in any other of its uses. In playback, the response is instantaneous.
09-01-2013, 12:12 PM   #4
Veteran Member
AndrewG NY's Avatar

Join Date: Dec 2006
Location: Chappaqua, NY
Photos: Gallery
Posts: 678
Your description sounds a lot like a wonky e-dial. I have successfully straightened a problem like this on my old DS2 with a squirt of electrical contact cleaner and working the dial however this may be trickier on the sealed k-7. I am a current k-7 owner and wouldn't hesitate to try this again myself but we each have our own tolerances for risks and willingness to seek professional repair.

Does it seem just as finicky in TAv, X, or Tv mode or in M mode with the dial functions reversed? Or with D-BG4 grip if you have one?

I think I can help you with your other question -- check custom setting #17 'Remote with Bulb' -- can open/close shutter by clicking remote when in B mode.

09-01-2013, 06:06 PM   #5
Veteran Member
derelict's Avatar

Join Date: Jul 2011
Location: NoVa
Posts: 371
Original Poster
Well, it is still a bit laggy but I have been working it and pulled out the can of Dust Off while working it. Seems to be improving but still a slight lag at times.
09-01-2013, 06:58 PM   #6
Pentaxian
calsan's Avatar

Join Date: Nov 2008
Location: Perth, Australia
Photos: Gallery
Posts: 1,367
the way to check would be to reverse the function of the e-dials in the custom settings and see if the behaviour changes.
09-02-2013, 07:31 AM   #7
Veteran Member
derelict's Avatar

Join Date: Jul 2011
Location: NoVa
Posts: 371
Original Poster
QuoteOriginally posted by calsan Quote
the way to check would be to reverse the function of the e-dials in the custom settings and see if the behaviour changes.
I switched the dial assignments in M mode setting the rear dial to be shutter timing. The adjustments were much more responsive. I mostly use Av and Tv since I use older M lenses so I will leave the settings like they are. I am in M mode when running my M42 lenses on it. I will keep working the dial and maybe try some contact cleaner. The dial works, just not as smoothly as the rear one.
09-02-2013, 11:16 AM   #8
Site Supporter




Join Date: Nov 2011
Location: East central Indiana
Photos: Gallery
Posts: 600
If you try the contact cleaner, be sure and get the one that says "safe for plastic" . The normal cleaner will melt plastic.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, decrease, k7, meter, pentax help, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K7 Shutter Priority reset Mitch401 Pentax DSLR Discussion 4 08-31-2012 08:22 PM
Long Shutter Timing Technique Question derelict Photographic Technique 13 09-01-2011 11:26 PM
Change timing in countdown photo fekish Troubleshooting and Beginner Help 11 09-15-2010 11:50 PM
K7 built-in flash in M sinus007 Pentax DSLR Discussion 17 08-18-2010 08:22 AM
K7 Shutter speed with flash in Av dnmtsn` Flashes, Lighting, and Studio 15 05-25-2010 04:08 AM



All times are GMT -7. The time now is 02:50 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top