Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-10-2013, 07:06 AM   #1
New Member




Join Date: Aug 2012
Location: Tampa
Posts: 23
Camera Repair - is this normal?

I had sent my K5 out for repair at a place Pentax uses in Arizona. They received it July 23rd. As of this day, they are "still waiting on the part. They are in between moves so nothing has been sent to finish the repair". I understand that Corporate moves can be time consuming. But is this normal? For those that have had repair done, how long did it take you? Anyhow, my camera was still under warranty when I sent it out. Basically what happened what it just stopped shooting not sure if it's the shutter or what. I'm just getting frustrated. I have another camera but I just want to get an answer better than what they have been giving me since July . Thanks!

09-10-2013, 08:58 AM   #2
Loyal Site Supporter
THoog's Avatar

Join Date: Aug 2012
Location: North Carolina
Photos: Gallery | Albums
Posts: 3,485
If they are waiting to get a part from Pentax Japan, then six weeks isn't that much. I had to wait four months once. CRIS (the place in Arizona) is completely dependent on the manufacturer providing the parts. Hopefully, along with (re)building a dealer network in the US, Ricoh will (re)build the US service structure and speed the flow of parts from Asia.
09-10-2013, 10:37 AM   #3
New Member




Join Date: Aug 2012
Location: Tampa
Posts: 23
Original Poster
Yeah Pentax is the one that told me they are waiting for a part from the Philippines but also, until the move has been done, they are not sending out any parts. It's just frustrating when they have no idea on when that move is supposed to be completed. Fortunately I have another camera I can use.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, camera repair, moves, pentax help, repair
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is this normal behavior for SDM lens everydaylife Pentax SLR Lens Discussion 8 07-01-2013 06:18 PM
LCD display of ISO, is this normal? djmundy Pentax K-5 4 11-23-2012 01:38 PM
Is this normal? Alizarine Troubleshooting and Beginner Help 15 08-02-2012 08:12 AM
There is air blow out when I zoom my 16-50, is this normal? liukaitc Pentax SLR Lens Discussion 21 05-10-2012 08:55 AM
Is This Normal? RGold Pentax K-5 5 01-22-2012 03:25 PM



All times are GMT -7. The time now is 09:39 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top