Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-16-2013, 03:16 PM   #1
New Member




Join Date: Sep 2013
Location: Evergreen, CO
Posts: 2
K200 Loss of Power

This month, my Pentax K200D will not register fully charged brand new batteries. I used to run
Duracel AA 's but got tired of replacing the batteries. Have switched to Lithium AA's with great success until now. Just purchased brand new Lithium's, checked the voltage (they are good) and now I can only take about 4 or 5 daylight pictures until the battery indicator shows depelted and I can't shoot another picture. Sometimes, if I let the camera set, I can get a couple of extra shots. Most times nothing. I re-checked the batteries, they are full as are the previous set of Lithium's I replaced. Any pointers about loss of power with the body?? I'm stumped.

09-17-2013, 08:24 AM   #2
Site Supporter
tomwil's Avatar

Join Date: May 2009
Location: Maryland USA
Posts: 778
QuoteOriginally posted by Ssmith45 Quote
My Pentax K200D will not register fully charged brand new batteries ...
This thread, and especially this post, will explain what the problem is, and a possible solution.

Also, Eveready Lithiums are known to have problems at times.
09-18-2013, 06:09 PM   #3
Veteran Member
kkoether's Avatar

Join Date: Jul 2008
Location: Huber Heights, OH, USA
Photos: Gallery | Albums
Posts: 573
One easy thing to try is using a pencil eraser to clean the battery contacts in the camera. They may look clean but they can build up a layer on them that will cause a voltage drop that CAN cause the issue your seeing. Good Luck!
09-19-2013, 04:03 PM   #4
New Member




Join Date: Sep 2013
Location: Evergreen, CO
Posts: 2
Original Poster
Thanks for the pointers. I am going to try the Sanyo eneloop batteries & see if that finally ends the problem. There was also some very interesting reading on other threads about the initial power requirement for start-up that was helpful. I'll let you know how the eneloops work after putting them through the paces.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, brand, loss, pentax help, power
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cautionary Tale: Unexpected Total Loss of Photos from SD Card lectrolink Pentax DSLR Discussion 17 12-03-2012 01:50 AM
Loss of tactile feedback in some buttons bwDraco Troubleshooting and Beginner Help 3 01-08-2011 07:48 PM
Loss of aperture control on K100D teamgs Pentax DSLR Discussion 4 09-25-2010 01:00 PM
The loss of High School Photography Classes VaughnA General Talk 34 03-09-2010 06:13 PM
Loss of exif data Alfie1965 Digital Processing, Software, and Printing 5 09-12-2007 11:13 PM



All times are GMT -7. The time now is 11:46 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top