Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-21-2013, 04:06 AM   #1
Site Supporter
disco_owner's Avatar

Join Date: Apr 2012
Location: Sydney
Photos: Gallery | Albums
Posts: 1,608
K-5 IIs Firmware Update - A Coincidence / Draw your own conclusion

ok guys , this has got me really puzzled ,

Friday night , I downloaded the windows/Mccintosh Firmware for K-5 II s and copied the .bin file on my spare memory card,

inserted the meomry card into the card slot and followed all the steps neccessary to update the firmware.

Once completed , I turned the unit off and back on the confirmed the new Firmware was updated to Ver 1.05.

Saturday morning I was booked into a Studio photography workshop, once I arrived , we helped set up the studio lighting and I asked one of the Female Photogs to take

a photo of me with my camera to check the lightin and flash power was ok.

one shot and the camera decided it didn't want to fire anymore shots.

Mirror would not swing up by pressing the shutter Nor would Hitting Liveview displayed the image.

So thinking it may be my batteries , I swapped the batteries with ones I had fully charged from the Night Before and still nothing.

the Camera would not fire a single shot ?? very strange . I had tested it the Night before post updating the Firmware and it was worked fine

so I borrowed a canon to continue the workshop for the weekend , On Sunday night while I was sitting at my Computer desk looking at my images

I decided to grab the camera and see if I could get it to fire a shot once again. and yup it was working once again.

09-21-2013, 05:07 AM   #2
Site Supporter
daacon's Avatar

Join Date: Mar 2007
Location: Alberta,Canada
Photos: Gallery
Posts: 20,831
Go to your menu , Custom , uncheck the Murphy s Law option. Glad you were able to at least get the shoot in. No idea but I am going to head out now for the first time with 1.05 update.
09-21-2013, 05:43 AM   #3
Lens Buying Addict
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,459
Didn't you read the part about the new fingerprint unlock feature in Ver. 1.05s?

Oh wait.

09-21-2013, 06:28 AM   #4
Pentaxian
Neville's Avatar

Join Date: Jun 2012
Location: Durban, South Africa
Photos: Gallery
Posts: 556
I had a similar experience recently while visiting a local game reserve.

My K-5II would power up momentarily and then shut down when I tried to wake it up to take a shot. I swopped the battery, but the problem persisted. Now I was panicking, as it was the only camera I had with me.

Then I noticed that the cover for the sd card was not closed properly, so I closed it and all was well again!

09-21-2013, 06:51 AM   #5
Site Supporter
disco_owner's Avatar

Join Date: Apr 2012
Location: Sydney
Photos: Gallery | Albums
Posts: 1,608
Original Poster
QuoteOriginally posted by daacon Quote
Go to your menu , Custom , uncheck the Murphy s Law option.Glad you were able to at least get the shoot in. No idea but I am going to head out now for the first time with 1.05 update.


I think "Murphy" is telling me to change outfits to canon oh boy , what a Horrible piece of equipment ( slight Tongue in Cheek ) , may be I'm biased towards my Beloved pentax's ergonomics and Button layout.


QuoteOriginally posted by monochrome Quote
Didn't you read the part about the new fingerprint unlock feature in Ver. 1.05s?

Oh wait.

That would be a neat Feature to have , Fingerprint recognition to unlock your Camera.
09-21-2013, 06:55 AM   #6
Site Supporter
disco_owner's Avatar

Join Date: Apr 2012
Location: Sydney
Photos: Gallery | Albums
Posts: 1,608
Original Poster
QuoteOriginally posted by Neville Quote
I had a similar experience recently while visiting a local game reserve.

My K-5II would power up momentarily and then shut down when I tried to wake it up to take a shot. I swopped the battery, but the problem persisted. Now I was panicking, as it was the only camera I had with me.

Then I noticed that the cover for the sd card was not closed properly, so I closed it and all was well again!

Hi Neville , we even updated the firmware again as someone suggested it might have been Just that , and made sure there was nothing silly we had done wrong that caused the behaviour i.e like leaving the SD card cover... etc
09-29-2013, 11:52 AM   #7
Loyal Site Supporter
OrchidJulie's Avatar

Join Date: Jun 2012
Location: Magic City
Photos: Gallery | Albums
Posts: 1,286
QuoteOriginally posted by Neville Quote
I had a similar experience recently while visiting a local game reserve.

My K-5II would power up momentarily and then shut down when I tried to wake it up to take a shot. I swopped the battery, but the problem persisted. Now I was panicking, as it was the only camera I had with me.

Then I noticed that the cover for the sd card was not closed properly, so I closed it and all was well again!
I had a similar egg-on-face moment a couple of days ago, with the "company" D80 that I have to use at work. Grabbed the camera to shoot something (boss breathing down my neck about it...), turned it on, got it to focus, then nada, zip, zilch. Little beeps, no shutter. <bad language>. Turned it on and off a few times, no joy. Starting to sweat... then I (finally) looked at the LCD and saw the "E" code. No card in the camera! I had removed it to dump some previous images and never took it out of the reader... fortunately nobody but me knew what the "problem" was that I "fixed"...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, card, fire, firmware, night, pentax help, shot, studio
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Firmware for K-500, K-50, K-5 II, K-5 IIs, K-5, K-30, K-01, K-r, and 645D is out Adam Pentax News and Rumors 60 09-16-2013 05:46 AM
New Firmware For K-01, K-30, K-5, K-5 II, K-5 IIs, K-r Adam Pentax News and Rumors 63 02-18-2013 02:04 PM
K-5 II and K-5 IIs Firmware 1.01 Available Adam Pentax K-5 10 01-18-2013 08:35 AM
Will K-5II/IIs firmware work for K-5 Classic? LIJ Pentax K-5 18 11-04-2012 09:16 AM
K-5 MF, AF confirmation update.... (conclusion) JohnBee Pentax K-5 25 10-08-2011 06:31 PM



All times are GMT -7. The time now is 03:11 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top