Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-22-2013, 12:05 PM   #1
New Member




Join Date: Sep 2013
Posts: 5
K5 problem with shutter and lense

Hi,
I bought my first DSLR the other day from ebay, a pentax k5 with the factory 18-55 lens bundled with a sigma DG70-300.
I am having a weird issue with the shutter in all but the green mode. I press the button all the way and the camera starts to beep, then I have to press it again to take a shot. If I don't it just keeps beeping.

Also the sigma lens has some strange worm like marks on the perimeter of the front lens. Is this normal?
I am attaching 2 images of the lens.

Should I return it?
Thank you.

Attached Images
   
09-22-2013, 01:03 PM   #2
Forum Member




Join Date: Sep 2013
Location: Niedersachsen, Germany
Posts: 67
Oh, I would hate to see this in my lens.
Please mind that I consider myself as quite a newbie, so don't be too alarmed when I tell you that I suspect it is fungus.

Regards,

Bernie
09-22-2013, 01:26 PM - 1 Like   #3
Pentaxian
pixie's Avatar

Join Date: Sep 2012
Location: Visitacion Valley, CA
Photos: Gallery
Posts: 657
It sounds to me as if your camera was in mirror lock-up drive mode. Press the upper button of the 4 way controller, and then go to a single frame shooting (all the way on the left) or other mode.
09-22-2013, 01:31 PM   #4
Veteran Member




Join Date: Jul 2009
Location: London
Posts: 889
QuoteOriginally posted by Bernie_Rain Quote
Oh, I would hate to see this in my lens.
Please mind that I consider myself as quite a newbie, so don't be too alarmed when I tell you that I suspect it is fungus.

Regards,

Bernie
I agree

09-22-2013, 01:44 PM - 1 Like   #5
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,424
QuoteOriginally posted by Pentaxpixie Quote
It sounds to me as if your camera was in mirror lock-up drive mode. Press the upper button of the 4 way controller, and then go to a single frame shooting (all the way on the left) or other mode.
My thoughts as well.

It is likely that many of the controls and settings are at other than default values. Some time with the manual will help you iron things out.

As for the lens, that does look sort of like fungus.

And finally...Welcome to the Pentax Forums!!!


Steve
09-22-2013, 01:55 PM   #6
Pentaxian
pixie's Avatar

Join Date: Sep 2012
Location: Visitacion Valley, CA
Photos: Gallery
Posts: 657
QuoteOriginally posted by stevebrot Quote
It is likely that many of the controls and settings are at other than default values. Some time with the manual will help you iron things out.
Yes, the manual is your biggest friend. Just in case your camera didn't come with its manual, you can get a PDF version here: Operation Manuals Download : Support & Service | RICOH IMAGING
09-22-2013, 03:31 PM   #7
New Member




Join Date: Sep 2013
Posts: 5
Original Poster
thank you

Thank you all very much for the prompt reply.
The camera was indeed in mirror lock-up drive mode on arrival and although I searched the manual it didn't occur to me :-/
As for the lense I will contant the seller to return it.

P.S. Great forum. I'll stick to it.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k5, lens, pentax help, photography, press, shutter, sigma
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
which lense with k5 do I need maxibaut Pentax K-5 5 04-25-2013 05:40 PM
Random problem with k5 and d fa 100 wr Vindemiatrix Troubleshooting and Beginner Help 5 11-09-2012 04:56 PM
Pentax k5 with 50mm 1:1.7 and shutter speed smack1019 Pentax K-5 10 03-04-2012 03:52 PM
K5 Shutter release problem 10speeduk Pentax K-5 4 11-28-2011 12:55 PM
Super Program problem with film advance and shutter release Laurie60014 Pentax Film SLR Discussion 6 07-18-2008 09:00 PM



All times are GMT -7. The time now is 10:24 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top