Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-02-2013, 02:18 PM   #1
Senior Member




Join Date: Jan 2010
Location: Poland, Świdnik
Photos: Gallery
Posts: 220
Problem with Pentax k-x and pentax-a 1.7/50mm

Hello,

I know that there are a lot of topics like that but i haven't find an answer to my question..

I am owner of Pentax k-x with kit + pentax 55-300 lenses for about 3 Years and till lately i was more like a Point and shoot type of photographer :P

I wanted some change and i bought the legendary Pentax-a 1.7/50mm and i think there is something wrong with it..
What i did:
1. I set the "Allow aperture setting other than A" to 2 (allowed) in the custom function menu
2. set camera to Av
3. set lens to A mode
4. conect the lens to body -> lens gets to 1.7
5. turn on camera - set 50mm
6. i don't get any information on what aperture am I using... I always see "F ----"...
Using the wheel on the body doesn't change anything.. not when set to A not when set to anything else.. I can see that lens is still on 1.7
when body i set to M or Av using the aperture ring on lens also doesn;t change anything.. I can see that lens is still on 1.7
using aperture ring on lens that is not conected to body, works fine

I wnet through photos of other pentax-a 1.7/50mm lens in internet and i see that in the place where on my picture is whole, they have a metal ball (at around 8 o clock on the picture)

Should i send tehm back to the seller as a broken stuff? or is it normal? should i get the actuall F on body when lens is conected? shouldn't the wheel on body work and set apperture?

help please..

Attached Images
View Picture EXIF
PENTAX K-x  Photo 
10-02-2013, 02:36 PM   #2
Inactive Account




Join Date: Dec 2008
Location: North Carolina
Photos: Albums
Posts: 1,720
The A contact is missing, there should be a brass contact in that hole.
10-02-2013, 02:39 PM   #3
Site Supporter




Join Date: Mar 2012
Location: Perrineville, NJ
Posts: 1,365
The lens is defective, the contact is indeed missing. Without the contact (and whatever circuitry might be missing beneath it), you effectively have an M lens, rather than the A lens you paid for.
10-02-2013, 02:45 PM   #4
Site Supporter
JimJohnson's Avatar

Join Date: Jan 2012
Location: Lake Superior - Michigan
Photos: Gallery
Posts: 2,271
This is not a K-A 50mm f/1.7 lens. If it was, there would be a series of contacts on the mounting flange to match up with those on your camera body. I'm willing to bet the aperture ring does not have an 'A' position just above F/22. This is either a K or M series lens.

The contact points on the lens flange of an A-series lens tells the camera the aperture min/max - and there is one contact (the 'A' contact) that extends ONLY when the aperture ring is in the 'A' position.

Your K-x has no means of detecting the aperture setting on the lens (thus the F - - - you are seeing). The K-x depends on the aperture being in the 'A' position which allows the aperture selection to be controlled by the camera body rather than than by the lens.

10-02-2013, 02:48 PM   #5
Inactive Account




Join Date: Dec 2008
Location: North Carolina
Photos: Albums
Posts: 1,720
QuoteOriginally posted by JimJohnson Quote
This is not a K-A 50mm f/1.7 lens. If it was, there would be a series of contacts on the mounting flange to match up with those on your camera body. I'm willing to bet the aperture ring does not have an 'A' position just above F/22. This is either a K or M series lens.
It is an A lens, the A 50mm f1.7 just has the A contact (which is missing, but you can see the hole where it belongs) and one insulator (which is visible).

You could wedge a small ball of aluminum foil in the hole, just enough to touch the contact of the body and it will work as expected.
10-02-2013, 03:56 PM   #6
Senior Member




Join Date: Jan 2010
Location: Poland, Świdnik
Photos: Gallery
Posts: 220
Original Poster
Thank You all for quick answers

The good news is that it is not my fault that it doesn't work the bad news is that i could have bought the M lens for half the price..

@elliott
I have seen the trick You are talking about, but i prefer to get what i paid for

I am gone contact the seller and ask either for full refund and send back the lens, or 50% refund for selling the broken stuff..

Thanks all. Topic can be closed as resolved
10-02-2013, 05:41 PM   #7
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,438
QuoteOriginally posted by gelokrol Quote
but i prefer to get what i paid for
Exactly.


Steve

FWIW...the M 50/1.7 also has a much better build. I own both lenses.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: SMC Pentax 50mm A 1.7 and a 50mm M 1.4 Excellent condition davidgreen3003 Sold Items 2 05-10-2013 08:41 AM
For Sale - Sold: Pentax-A 50mm 1.7 1:1.7 with caps sdflyer Sold Items 2 06-13-2012 03:33 AM
For Sale - Sold: SMC Pentax-FA 1:1.7 50mm SMC Pentax-A 1:2.8 135mm Sears MC 1:1.7 50mm Designosophy Sold Items 9 06-12-2012 06:28 AM
Problem with K-X and old 50mm 1.7 M lens. cantari Troubleshooting and Beginner Help 2 04-13-2010 04:25 PM
For Sale - Sold: Pentax K-X (black) with kit lens and F 50mm f/1.7 lens tangus Sold Items 3 01-06-2010 09:42 AM



All times are GMT -7. The time now is 10:05 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top