Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-02-2013, 03:05 PM   #1
Junior Member




Join Date: Aug 2013
Location: Schwyz
Posts: 44
SDHC Problems with K5

Hello

I own an Pentax K20D with about 8 pcs SDHC Card. They work without any problem. These are really old card mostly Class 4 and 6

Now I bought a K5. Nearly half of my cards has problems. 2 of them are not readeble or even to has an option to format. 3 of the other cards has errors wrting the data.

I checked the firmware and this is the latest firmware 1.15. What Can I do, these Cards works fine with K20D and not with the K5. I would understand that maybe the newest SDHC or SDXC Class 10 Cards has problems but not the older Class 4 and 6.

Who is able the help me. Should I downgrade to an older version of the firmware?

Regards
Gérard

10-02-2013, 03:49 PM   #2
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,065
I have been using San-Disk 16 gig. class 10 cards for couple years now, no problems. I think you should upgrade and get a class 10, then format it in the K5, that should take care of your dilemma.

Cheers,
10-02-2013, 06:16 PM   #3
Site Supporter
gbeaton's Avatar

Join Date: Apr 2012
Location: Montreal
Photos: Gallery
Posts: 326
I also use 16GB class 10 on the K5II - and used them on the K20. Neither had problems.

You upgraded your camera... you need to upgrade your SD card.
10-02-2013, 11:16 PM   #4
Junior Member




Join Date: Aug 2013
Location: Schwyz
Posts: 44
Original Poster
Hello

I can't image that the K5 could only work on class 10 cards. With the old Class 4 and 6 which I used in the K20D should everything work, maybe slower. I tried it with 2 bodys of the K5 with the Firmware 1.15 and they both give the same useless result.

Regards
Gérard

10-03-2013, 04:45 AM   #5
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,331
Put the card into your K20D, and format it in-camera. Now try it in the K-5. Better?
Also, make sure you push the card all the way in, until it clicks into place. And to remove it, just push it in again and it should pop out. Sorry if you already know this, but we have had posters before who had the problem with this step

Reverting to an older firmware is hard and not recommended, though the camera can be tricked to do it. I dont know how, I think there are some forum posts about this, use the search function. But I doubt it would fix your problem.
10-03-2013, 05:47 AM   #6
Junior Member




Join Date: Aug 2013
Location: Schwyz
Posts: 44
Original Poster
QuoteOriginally posted by Na Horuk Quote
Put the card into your K20D, and format it in-camera. Now try it in the K-5. Better?
Also, make sure you push the card all the way in, until it clicks into place. And to remove it, just push it in again and it should pop out. Sorry if you already know this, but we have had posters before who had the problem with this step

Reverting to an older firmware is hard and not recommended, though the camera can be tricked to do it. I dont know how, I think there are some forum posts about this, use the search function. But I doubt it would fix your problem.
Sorry, this is not working. Format on K20D is OK. In both K5 Body they are not readeble. The Format Options is hidden :-(
10-04-2013, 12:32 PM   #7
Senior Member
screwdriver222's Avatar

Join Date: Oct 2011
Location: Plymouth
Photos: Gallery | Albums
Posts: 127
You could try formatting them in a pc using FAT 32 and do a full format not the quick format.
10-04-2013, 12:34 PM   #8
Junior Member




Join Date: Aug 2013
Location: Schwyz
Posts: 44
Original Poster
Hello

I both format them on a PC and on a mac with SD Formatter, still no chance to see them in the K5, in the K20D everything works fine

Gérard

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anybody with mirror problems with K30? Focus problems. simbon4o Pentax K-30 & K-50 14 08-28-2013 10:39 PM
Any freezing problems with K30?(like those with K5) or any other problems? simbon4o Pentax K-30 & K-50 21 01-03-2013 01:54 PM
K5 & SDHC UHS-I Cards AussieTrev Pentax K-5 8 05-19-2012 10:06 PM
K5 problems Sifu Pentax K-5 49 10-26-2011 12:09 AM
K5 with 16-50mm Auto-ISO problems?? conradcjc Pentax K-5 8 04-18-2011 02:51 AM



All times are GMT -7. The time now is 04:11 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top