Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-10-2013, 02:11 PM   #1
New Member




Join Date: Oct 2013
Posts: 2
Pentax ME Super

I recently bought a Pentax ME Super for a friend after I got a K1000, which I love, and when I got home I noticed something was wrong. The mirror was up, the shutter wouldn't move, film advance was stuck and the shutter wouldn't fire. I got the shutter, film advance and mirror to move by carefully moving the shutter up manually and that fixed that. But it still wouldn't fire, it would wind but not fire, I opened the bottom cap and noticed the film transport wasn't catching. I forcefully twisted and messed with it and 1 every 4 shots would fire and I get fidgeting with that little circle. I got it to go to one every 2 then I little more and I got it fixed! I now own a like new Pentax ME Super and K-1000 and love both. Film rocks!

10-10-2013, 04:03 PM   #2
Pentaxian
Paleo Pete's Avatar

Join Date: Jun 2010
Location: Texas
Photos: Gallery | Albums
Posts: 2,877
Sounds like it's in need of a good clean and lube. That pretty much describes what a couple of mine are doing, or similar anyway, so I retired them and have one working ME right now and a Minolta SRT101. One will fire but it takes 15 minutes before the mirror will drop back down...can you say Clean Me????
10-10-2013, 04:34 PM   #3
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,216
QuoteOriginally posted by Paleo Pete Quote
One will fire but it takes 15 minutes before the mirror will drop back down...can you say Clean Me????
Talk about some sticky light seals.
10-10-2013, 04:56 PM   #4
Pentaxian
Paleo Pete's Avatar

Join Date: Jun 2010
Location: Texas
Photos: Gallery | Albums
Posts: 2,877
Oh yeah, gummed up for sure...

10-10-2013, 07:34 PM   #5
Veteran Member
OrangeKx's Avatar

Join Date: Nov 2011
Location: Vancouver, WA
Photos: Gallery
Posts: 808
It's old and needs some TLC. Mine did and after getting it cleaned/repaired it's as good as new.
10-11-2013, 02:42 PM   #6
New Member




Join Date: Oct 2013
Posts: 2
Original Poster
Yep, it's was very dirty! Once I got it working, it's just dandy! I still love my k-1000 though, he's a beaute!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advance, film, fire, love, mirror, move, pentax, pentax help, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Choosing a flash for Pentax ME Super kindakaa Pentax Film SLR Discussion 11 11-18-2014 03:06 PM
Pentax Me Super - Film Loading Advice/Question jstillion Pentax Film SLR Discussion 4 07-13-2013 11:50 AM
Pentax ME Super Problems TommyRee Pentax Film SLR Discussion 3 01-03-2013 12:39 PM
Pentax ME & ME Super parts compatibility jadedrakerider Pentax Film SLR Discussion 8 11-29-2009 03:28 PM
difference between Pentax ME Super & Pentax Super Program hinman Pentax Film SLR Discussion 3 10-19-2008 02:19 PM



All times are GMT -7. The time now is 02:32 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top