Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-27-2013, 08:22 AM   #1
Site Supporter
Dartmoor Dave's Avatar

Join Date: Aug 2012
Location: Dartmoor, UK
Photos: Albums
Posts: 975
K100D firmware memory dump?

I’m hoping that somebody here might have experienced the following error screen on a K100D and can offer some advice:




The problem began with what I thought might be the nylon gears jamming in the mechanism that flips the mirror. When I pressed the shutter I could hear the motor whirring, but the mirror didn’t flip and the shutter didn’t fire.

After a couple of weeks when all else had failed, I decided to enter debug mode and try the “RELEASE AGING”procedure. And sure enough, after the camera’s first dozen or so attempts to automatically fire, the mechanism seemed to free itself and the mirror and shutter began working again.

Problem solved, I thought.

So I turned the camera off and on again to re-enter debug and switch off RELEASE AGING. But now, instead of the debug menu, what I get is this error screen. Possibly the firmware preparing a memory dump?

For the record, the method I used to enter debug was AE-L plus INFO, then MENU MENU INFO.

K100Ds are so cheap to replace that it’s not worth spending any money on the problem, but if anyone can offer any suggestions I’d be very grateful.

10-27-2013, 09:59 AM   #2
Site Supporter
Dartmoor Dave's Avatar

Join Date: Aug 2012
Location: Dartmoor, UK
Photos: Albums
Posts: 975
Original Poster
The WAIT HS. . . screen has now cleared.

But the camera now appears to be stuck in RELEASE AGING, and doesn't respond to the button sequence to go back into debug to turn RELEASE AGING off.

So now I've got a mirror/shutter mechanism that seems to be working again, but a camera that refuses to come out of debug mode and let me start taking pictures again.

Aaargh!
10-27-2013, 01:41 PM   #3
Site Supporter
Dartmoor Dave's Avatar

Join Date: Aug 2012
Location: Dartmoor, UK
Photos: Albums
Posts: 975
Original Poster
Debug mode finally cleared. Full control of the camera restored. Mirror and shutter now operating normally. Firmware re-flashed just to make sure. Looks like I've got a working K100D on my hands again, at least for now.

It was probably corrupt firmware all along, even when I first thought it was the mirror motor jamming.

Please consider this thread SOLVED and CLOSED.
10-27-2013, 02:39 PM   #4
NKK
Veteran Member




Join Date: Mar 2009
Location: Malmö, Sweden
Photos: Gallery
Posts: 583
Good to hear you got it back up and running - great little cam, still use mine for M42 lenses

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
debug, fire, firmware, info, k100d, mechanism, menu, mirror, pentax help, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K100D Firmware....+ DaveG14 Pentax DSLR Discussion 7 06-08-2012 06:35 AM
K100D internal memory Camoz Troubleshooting and Beginner Help 3 04-28-2012 04:31 AM
k10 firmware for new memory cards? slip Pentax DSLR Discussion 4 02-17-2011 07:29 AM
ist DL and New Firmware - Largest Memory Card? iamnaeth Pentax DSLR Discussion 2 05-06-2010 06:28 PM
A few *ist D questions, Memory firmware Peter Zack Pentax Camera and Field Accessories 10 10-30-2007 08:53 PM



All times are GMT -7. The time now is 04:50 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top