Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-16-2013, 11:46 AM   #1
Inactive Account




Join Date: Nov 2009
Location: Ninole, Hawaii
Photos: Gallery
Posts: 74
AF160fc Ring Flash issues

My camera is a K-5 IIs. I have had a new AF160fc Pentax ring flash sitting here for 3 yrs. without use. I installed the proper batteries, the ready light came on in about 7 sec. as advertised. I set "A" on the aperature ring and "A" on the ring flash control head.
Took my first pic with no issues. Waited for 7 sec. to recharge and no ready light or recharge. Changed batteries. Took a successful flash pic again. Ready light and recharge again not occurring, i.e. no buzz. So, if I want the ready light to come on,
I must turn the flash switch off after each pic. Is there some camera setting I'm missing? Or???? This is my third Pentax ring flash and they all seem to be crapola. Any answers would be appreciated.

11-16-2013, 01:30 PM   #2
Veteran Member




Join Date: Mar 2007
Location: Christchurch, New Zealand
Photos: Gallery
Posts: 433
What mode were you using on the camera? Av,M,Tv? What shutter speed was selected. The AF-160FC will probably not file when the speed in faster that 1/180 sec.
11-16-2013, 07:53 PM   #3
Inactive Account




Join Date: Nov 2009
Location: Ninole, Hawaii
Photos: Gallery
Posts: 74
Original Poster
As a macro photographer I always use Av mode. Took a few blue mushroom pics and the darn thing decided it liked working with the IIs after all and now works fine. Machines%^&*()_
Thanks. Years ago I used a ring flash with my older Pentax, but when I got a K-10 and went to a 50mm macro and put my DFA100 in the drawer, I stopped using using ring flash. For some reason I thought I'd try it out
again. It works well with the 50mm macro, so when not in the jungle will start using it again after I buy some stock in lithium batteries.
11-16-2013, 07:57 PM   #4
Pentaxian
Digitalis's Avatar

Join Date: Mar 2009
Location: Adelaide.
Posts: 8,534
you don't happen to have updated the firmware on your camera recently? I had an issue like this after a firmware update on my Pentax K7, AF160FC would only fire once after the camera had been switched on. I have had my AF160FC for years and it has never let me down, I have used it quite a bit on my K5IIs without issue, but then again I never use the A setting on mine - I always work manually.



Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, flash, issues, light, pentax, pentax help, pic, recharge, ring flash, sec
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax AF160FC macro ring flash baro-nite Sold Items 2 03-19-2013 11:17 AM
For Sale - Sold: Pentax AF160FC Auto Macro Ring Flash neil Sold Items 4 02-17-2013 07:55 PM
Thinking about a ring flash (AF160FC) stormtech Flashes, Lighting, and Studio 22 03-13-2012 07:01 PM
AF160FC ring flash rvannatta Flashes, Lighting, and Studio 3 10-09-2011 12:57 AM



All times are GMT -7. The time now is 09:20 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top