Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-21-2013, 11:13 PM   #1
New Member




Join Date: Nov 2013
Posts: 4
*ist DL suddenly showing only black frames...

Hi folks,
My venerable and until now, trouble free *ist DL, has suddenly stopped functioning...

It turns on and shows a display on the LCD
Autofocus and all icons display correctly
Flash works...

But the resultant 'image' is all black (hehe, yes...I HAVE removed the lens cap!)

In review mode I can see all previous images perfectly and where the new ones should show, only the frame number is visible on a black background.

I have removed and replaced batteries,card,lens and made sure all is working perfectly...even reset it to factory defaults.

But still "the black Screen of Death"...not even an error message because it appears to think it's fine.

I'm rather worried that my CCD has died....it has suffered no trauma to my knowledge and has been sitting in it's usual spot in my drawer since the last time I successfully used it. No-one has access to it or has used it besides myself.

Can any knowledgeable folks here help me get a handle on what may be happening?

Thanks :-)

11-21-2013, 11:17 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,957
Hmm, the K-3 might be smiling at you We see threads like these from time to time and usually it ends up being either the sensor or the motherboard that's crapped out. I wish I could be of more help!

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

11-22-2013, 12:05 AM   #3
New Member




Join Date: Nov 2013
Posts: 4
Original Poster
Thanks so much Adam...I think...LOL!!! What sort of money would I be looking at to repair my old 'baby' if that was the case? As a percentage of the cost to replace, I mean.

I love the *ist DL because I didn't need fancy schmancy batteries...I could get away with disposable Lithium AAs in a pinch, and 6 megapixels is plenty for me...not needing to print billboard posters,hehe. My husband has the K-r and it's jolly nice but I hadn't factored a new camera into my budget this year.
I'll have to wander off to read your K-3 review...

Thanks again
Charmian
11-22-2013, 12:13 AM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,957
QuoteOriginally posted by Charmian Quote
As a percentage of the cost to replace, I mean.
>100% these days, assuming they can even find the proper parts

If you're in love with your DL, I would of course replace it, but the K-x or K-r would be a huge upgrade over it at a very small premium.

If you enjoy using AA batteries and want to go with something new, take a look at the K-500, which ships with an AA battery holder by default in the US:

Pentax K-500 Review - Introduction - PentaxForums.com
Pentax K-500 | B&H Photo Video

There might be some nice deals on either the K-500 or K-50 next week... (black friday).


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

11-22-2013, 12:38 AM   #5
New Member




Join Date: Nov 2013
Posts: 4
Original Poster
Thanks Adam,

I've just been looking over the specs on the K-500 as it happens...that may be what I'm looking at....hmmmm

Cheers
Charmian :-)
11-22-2013, 10:32 PM   #6
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Some things that can cause black pictures:
  1. The mirror does not flip up when you press the shutter button.
  2. The shutter does not open when you press the shutter button.

For the first one, does the viewfinder go dark when you take a picture?
For both, you can remove the lens and look into the mount when you take a picture. You should see the mirror move up and down and the shutter open and close (you might want to use a slightly longer shutter speed (e.g. 1/2 sec) for this). You can also use the sensor cleaning function for this (not familiar with your camera but I assume it has one) to see what happens; the mirror should flip up and the shutter should open (so the sensor is exposed for cleaning).

Is it worth repairing? I doubt it but that's always a personal call (and you might to score another camera first for parts )
11-22-2013, 10:49 PM   #7
Veteran Member




Join Date: Oct 2013
Posts: 402
Is there a sensor cleaning mode where you can visibly check to see if the shutter is functioning? Or full manual mode low shutter speed where you can look into the body and check its function?
11-22-2013, 11:07 PM   #8
New Member




Join Date: Nov 2013
Posts: 4
Original Poster
Thanks for the suggestions, but yes, both the shutter and mirror are functioning as they should. There is a clean function and I had already checked that the mirror flipped up.

Everything looks spotless, no signs of corrosion,foreign objects, dead rats or chewing gum, LOL!!!

I'm not wedded to it, but it was a gift from my husband and I like it and am used to all it's habits. (Hehe, sounds like my husband too!)

I'll give the service folks a call and see what they say, in the meantime my husband has let me use his K-3 whenever I want, so that's what I'll do for now...I'm in Australia so no Black Friday sales, but a K-500 would set me back $625 AUD body only. This gives me an idea of what to compare a repair cost to...if it can even be done.

Cheers
Charmian

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
*ist, *ist dl, *ist dl..help, ccd, ccd cmos, display, dl, folks, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black Bar - ist-DL shutter failure? Rashedul Pentax DSLR Discussion 6 04-02-2012 04:32 PM
Pentax *ist DL - pictures come out black? jamart27 Troubleshooting and Beginner Help 12 01-07-2012 01:02 PM
Pentax ist DL...screen not showing any data! Debra Heschl Troubleshooting and Beginner Help 3 10-28-2011 08:21 AM
ist DL makes black shots Pau Pentax DSLR Discussion 2 01-06-2009 02:52 PM
Help needed with *ist-DL and black pics smmoore Pentax DSLR Discussion 7 10-14-2007 10:08 PM



All times are GMT -7. The time now is 06:54 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top