Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-21-2013, 08:48 PM   #1
Inactive Account




Join Date: Dec 2013
Location: Melbourne
Posts: 28
Pc connection and pictures wont take

My k30 is about 3-4 month old and ive noticed a few problems with it, 1- when connected to my pc it dropes in/out depending on if im holding it, tipping it to the side ect its almost like looking for phone reception, moving it around trying to stay connected. ...

2- another issue im having is ( its happend 3 times) ill turn it on, go to take a picture and it does its focus thing all set and .....freezes, wont take the pic wont switch to view mode wont do a thing. Its fully charged and I have to turn it on/off twice before it works again



12-21-2013, 09:17 PM   #2
Site Supporter
SpecialK's Avatar

Join Date: Dec 2006
Location: So California
Photos: Gallery
Posts: 14,853
The connection problem sounds like a mechanical issue with the cord, or socket.
12-21-2013, 10:49 PM   #3
Pentaxian
Class A's Avatar

Join Date: Aug 2008
Location: Wellington, New Zealand
Posts: 9,177
QuoteOriginally posted by alouise Quote
...when connected to my pc it dropes in/out depending on if im holding it, tipping it to the side ect its almost like looking for phone reception, moving it around trying to stay connected. ...
This is the first time I'm seeing someone report a problem like this.

You could check whether it is the USB cable plug at the camera side by (gently) manipulating it instead of moving the camera. It could also be the cable which is at fault. Try bending it at several places when you encounter the problem again. Seems unlikely that something inside the camera is moving.

BTW, I initially also used the cable to transfer photos, but now exclusively remove the card from the camera, download the images, delete the images, and then return the card to the camera. Works a lot quicker for me.

QuoteOriginally posted by alouise Quote
2- another issue im having is ( its happend 3 times) ill turn it on, go to take a picture and it does its focus thing all set and .....freezes, wont take the pic wont switch to view mode wont do a thing. Its fully charged and I have to turn it on/off twice before it works again
A few Pentax cameras have a faulty mainboard that makes them behave in weird manners (freezing, mirror flipping, ...). You may find that the issue will disappear once your accumulator aged a bit as sometimes these issues are caused by faulty voltage regulators on the mainboard that cannot cope with a fully charged accumulator.

Have you upgraded your firmware yet?
Unless you have the latest version installed, I'd download the latest firmware for your K-30 and see whether that helps. Firmware upgrades often contain "silent" fixes so even if a certain bug is not documented in the firmware description, it could still be addressed.

I would certainly keep an eye on the freezing issue. If it persists, you should send in your camera to have it serviced within the warranty period.
12-21-2013, 11:02 PM   #4
Inactive Account




Join Date: Dec 2013
Location: Melbourne
Posts: 28
Original Poster
No I haven't upgraded firmware thank you I might get on that now



12-21-2013, 11:11 PM   #5
Site Supporter
RGlasel's Avatar

Join Date: Sep 2013
Location: Saskatoon
Photos: Gallery | Albums
Posts: 1,334
QuoteOriginally posted by Class A Quote
I would certainly keep an eye on the freezing issue
It's pretty easy to isolate or eliminate the cable as your problem, just move the end that goes in your camera a bit and see if that causes a problem. If you can't recreate the freezing by jiggling the cable ends (the part that plugs into your computer is much larger and much less likely to be a problem) then as Class A says, get your camera in for warranty service. If they can't replicate the problem at the warranty service depot, at least it will be documented, so if it fails completely for this reason shortly after the warranty period is over, you have a case for getting service covered under warranty.
12-21-2013, 11:17 PM   #6
Inactive Account




Join Date: Dec 2013
Location: Melbourne
Posts: 28
Original Poster
I have an inkling its my laptop ( very clumsy with items) ive dropped it 101 times but ill def check out the cord its on the list of things to do :P

12-21-2013, 11:17 PM   #7
Inactive Account




Join Date: Dec 2013
Location: Melbourne
Posts: 28
Original Poster
Freezing wise it hasnt done it for a month or so but ill keep my eye on it

12-21-2013, 11:58 PM   #8
Inactive Account




Join Date: Dec 2013
Location: Melbourne
Posts: 28
Original Poster
Just fiddling qith the cord.. seems its the connection to the camera it seems I need to push it in or down to connect



12-22-2013, 12:00 AM   #9
Inactive Account




Join Date: Dec 2013
Location: Melbourne
Posts: 28
Original Poster
I just took the card out and stuck it in the comp no fuss.. I think ill just do this in future

12-22-2013, 12:53 AM   #10
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
QuoteOriginally posted by alouise Quote
Freezing wise it hasnt done it for a month or so but ill keep my eye on it
Make sure to get it checked before warranty expires.
12-22-2013, 12:55 AM   #11
Inactive Account




Join Date: Dec 2013
Location: Melbourne
Posts: 28
Original Poster
Yeah definitely will

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
im, pc, pc connection, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery drain on PC connection Farside Troubleshooting and Beginner Help 14 09-16-2013 07:09 AM
K5 Connection to PC Sig0431 Troubleshooting and Beginner Help 8 04-14-2013 07:55 AM
K10D wont take pictures Tchn226 Troubleshooting and Beginner Help 12 11-27-2011 10:02 AM
K7 wont take pictures in dark?? XeroX Pentax DSLR Discussion 14 08-03-2010 04:41 PM
K10D and pc connection to strobes smokey Pentax DSLR Discussion 8 10-08-2007 02:22 PM



All times are GMT -7. The time now is 03:15 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top