Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-03-2014, 07:28 PM   #1
New Member




Join Date: Jan 2014
Posts: 2
New k-500 won't shoot on occasion ...

I'm new at this and just got my k-500 for Christmas. I love the camera and have been having fun with it but lately it seems to freeze for no particular reason. I'm pushing the button to shoot and nothing happens. If I turn the camera off, it will likely shoot but seems slow to do so. We changed the batteries and at first thought that seemed to help but something still seems off. If I didn't know any better I'd say the issue seems to arise when I'm pointing the camera at a downward angle but no idea why that should impact anything.

Any ideas? I realize this is probably user error but just don't know what I'm doing wrong...

01-03-2014, 08:53 PM   #2
Loyal Site Supporter
narual's Avatar

Join Date: Jun 2013
Location: South Bend (Notre Dame), Indiana
Posts: 1,934
Do you have it set to only take the photo if the image is in focus? I think it's under custom settings… Focus Priority vs Release Priority.

And since you say you're new at it -- you do know that you hold the button halfway down to engage autofocus, and then the rest of the way once the image is in focus, right? If you just jab the button, it's not always going to complete focus before it's expected to take the picture, not to mention you're shaking the camera a bit just when it needs to be held perfectly still.
01-04-2014, 07:08 AM   #3
New Member




Join Date: Jan 2014
Posts: 2
Original Poster
QuoteOriginally posted by narual Quote
Do you have it set to only take the photo if the image is in focus? I think it's under custom settings… Focus Priority vs Release Priority.

And since you say you're new at it -- you do know that you hold the button halfway down to engage autofocus, and then the rest of the way once the image is in focus, right? If you just jab the button, it's not always going to complete focus before it's expected to take the picture, not to mention you're shaking the camera a bit just when it needs to be held perfectly still.
That's helpful. Let me check into that setting. Thanks for all the suggestions! Your help is VERY appreciated.

I'll post back if one of those doesn't do the trick.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-500, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 won't turn on sophie100 Pentax K-5 16 06-01-2013 02:16 PM
Help! Pentax K-r won't turn on? Marie Anette Pentax K-r 9 02-10-2013 04:08 PM
Old K mount lens won't fit on my k-r body Timelime Troubleshooting and Beginner Help 10 02-10-2013 01:02 PM
zx-30 won't shoot monkeymaster Troubleshooting and Beginner Help 8 07-07-2012 09:15 AM
K-x won`t turn on Rick43 Pentax DSLR Discussion 6 03-25-2012 04:26 PM



All times are GMT -7. The time now is 03:36 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top