Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-08-2014, 11:02 AM   #1
Veteran Member
volosong's Avatar

Join Date: Sep 2006
Location: Antelope Valley, SoCal
Photos: Gallery
Posts: 663
50-135 SDM failed again!

Uugh! SDM Fixed by C.R.I.S. three years ago, minus a month. SDM failed again. If the optical quality of this lens wasn't so great, I'd sell the stupid thing.

01-08-2014, 11:33 AM   #2
Veteran Member




Join Date: Dec 2012
Posts: 482
QuoteOriginally posted by volosong Quote
Uugh! SDM Fixed by C.R.I.S. three years ago, minus a month. SDM failed again. If the optical quality of this lens wasn't so great, I'd sell the stupid thing.
I can understand your terrible dilemma. :-( The 50-135 is indeed utterly outstanding, image-wise. But SDM failure is really frustrating.
01-08-2014, 11:49 AM   #3
Loyal Site Supporter
narual's Avatar

Join Date: Jun 2013
Location: South Bend (Notre Dame), Indiana
Posts: 1,942
Why not convert it to screw drive?
https://www.pentaxforums.com/forums/10-pentax-slr-lens-discussion/208353-how-...-2-8-a-15.html
01-08-2014, 11:51 AM   #4
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,547
I gave up on the third failure with mine and went the opposite end of the spectrum: DA-L 55-300. At least it works, but I do miss the IQ of the 50-135, the quick shift. Do it over again, I'd keep it and use it with the AFA 1.7X. It would give me an 85-230 f/4.76. I had tried it a couple of times with the 1.7 and it worked really well.

01-08-2014, 11:51 AM   #5
Veteran Member
maxfield_photo's Avatar

Join Date: Mar 2011
Location: Cincinnati, OH
Posts: 1,215
I dropped my 50-135 back in May of 2013, and sent it in to CRIS. It took them quite a while to repair it, I didn't get it back until mid October. According to their site the parts were on backorder from the manufacturer, but I hear a rumor through the grapevine that they were waiting on new, stronger SDM motors from Ricoh. I'm hoping that was the case, but then I never had any problems with the old SDM motor in the lens.

I DO however have a problem with the SDM contacts in my K20d. I was changing lenses, didn't notice I had the camera on, and I think I started to cross thread the bayonet, and inadvertently shorted out the SDM circuit in the camera. But here's the thing, my 50-135 now operates with the screwdrive. I'm thinking if the camera can't detect that an SDM lens is attached, it defaults to using the screwdrive. It might be worth trying to cover your contacts on the lens with a piece of electrical tape. You'll have to do it at your own risk because you don't want to gunk up anything, but you might find that you don't need to have your lens repaired after all.


[Edit: Oh, didn't know about the debug mode trick that Natural linked. That sounds safer, try that first]
01-08-2014, 12:12 PM   #6
Veteran Member
gbeaton's Avatar

Join Date: Apr 2012
Location: Montreal
Photos: Gallery | Albums
Posts: 343
QuoteOriginally posted by volosong Quote
Uugh! SDM Fixed by C.R.I.S. three years ago, minus a month. SDM failed again. If the optical quality of this lens wasn't so great, I'd sell the stupid thing.
I'm not really happy with Pentax DA lenses. I have a DA 17-70 which is great except that it hunts for focus unless I put my finger on the focus ring - it can be really annoying when you're trying to get a shot. I also have a DA*60-250 and have had a couple of scary instances when the SDM system would not move as if the motor was weak. I figured it needed prodding so I exercised the focus ring manually until finally the thing would start working. So now every time I take it out, I exercise the focus ring manually, then using autofocus near-far-near-far etc. Then it works as expected.

Now I've just seen a video about a budget pro camera system and the guy recommended the K5iis (before K3 release) but no pentax lenses. He recommended all Tamron F2.8 lenses.

However, I have a couple of screw drive FA lenses and they are un-categoricly great lenses.
01-08-2014, 12:40 PM   #7
Loyal Site Supporter
narual's Avatar

Join Date: Jun 2013
Location: South Bend (Notre Dame), Indiana
Posts: 1,942
The only problem I've had with my screw drive 50-135 is gravity. It landed square on the hood, smashed the filter, and broke something loose inside. sending it for repairs when I finally get dug out from the blizzard.

It will be a little louder of course, but hey, it will get a speed boost for free with every screwdriver motor upgrade pentax applies to a new body.
01-08-2014, 01:01 PM   #8
Site Supporter
psychdoc's Avatar

Join Date: Jul 2010
Location: Bham
Photos: Gallery | Albums
Posts: 943
Sorry to hear about your problems.

I dropped my 50-135 about 3 months ago while removing it from the tripod and it looked pretty bad [like the barrel was fractured] and I debated about spending the money vs getting a tamron 70-200 instead but that is too big a lens.

In any case it was repaired by CRIS within a month or so for about 300 dollars. They said they replaced a bunch of little things and also the sdm motor. Seems to work perfectly. However, mine never had a problem with the sdm before I dropped it. I hope the new sdm motor stays as problem free as the old one as I must have had one of the good ones... So far so good though.

01-08-2014, 08:45 PM   #9
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,450
So...Is this a rant or a request for technical assistance?


Steve
01-08-2014, 10:54 PM   #10
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
QuoteOriginally posted by maxfield_photo Quote
I DO however have a problem with the SDM contacts in my K20d. I was changing lenses, didn't notice I had the camera on, and I think I started to cross thread the bayonet, and inadvertently shorted out the SDM circuit in the camera.
You're number two, I guess: https://www.pentaxforums.com/forums/10-pentax-slr-lens-discussion/85877-i-bro...t-happier.html
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
pentax help, sdm
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Has your SDM lens failed? (Official Survey) Adam Pentax SLR Lens Discussion 56 12-10-2014 07:52 PM
My 50-135 is SDM dead.... ruoyun.huang Pentax SLR Lens Discussion 20 03-29-2014 03:24 PM
DA 16-50 SDM Failed do I return for refund or get repaired fewing1 Pentax SLR Lens Discussion 9 01-31-2013 09:07 AM
For Sale - Sold: DA*50-135mm with failed SDM farfisa Sold Items 23 08-27-2009 05:05 AM
Lens offer from Amazon: DA* 50-135 SDM & DA* 16-50 SDM f8 Pentax SLR Lens Discussion 4 03-25-2008 04:45 AM



All times are GMT -7. The time now is 11:27 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top