Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-17-2014, 07:52 AM   #16
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,178
QuoteOriginally posted by altopiet Quote
Some people get so paranoid about a bit of dust and cleaning it, that they don't want to change lenses anymore...when you get to that stage, you might just as well sell your DSLR....
1+ to that!


Steve

01-17-2014, 02:48 PM   #17
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,219
QuoteOriginally posted by ClinchShots Quote
well I checked my sensor again and it looks fine I moved it around a bit to see if there is any scratches or specs and I see nothing

camera is pretty much clean now except for when I use the viewfinder

pictures are sharp and look good to the eye
Re Your Sensor....Turn on your dust removal in the Tool menu #4. I have mine set to start up. That will shake dust off the sensor when you start your camera. Periodically you will need to blow off the sensor with a Rocket Blower or something like it.

Re Viewfinder... Don't OCD on that one. That is part of life with interchanging lenses. Blowing it off with a rocket blower will help most of the time. Periodically I will drop my view screen and blow out the mystical dust particles that get behind it but you need to be in a dust free area and be careful when you do. It can be Gently removed and cleaned carefully also.
01-31-2014, 04:39 AM - 2 Likes   #18
Site Supporter
tomwil's Avatar

Join Date: May 2009
Location: Maryland USA
Posts: 778
QuoteOriginally posted by ClinchShots Quote
removed.
Courtesy of Google Cache in reference to camera sale:

QuoteOriginally posted by ClinchShots Quote
I just bought a K50 off the marketplace and I may be a stickler but it's the dirtiest camera I have ever handled.

I spent a good hour cleaning it top to bottom but I cant get the specks and small hairs or fibers out of what I believe is the eye piece

It could very well be elsewhere in the camera and just showing up when I look through the viewfinder.

any tips or should I just take it to get professionally cleaned?

it's erking me.

Also I seem to be getting some dark spots in all white photos with the camera in the corner sections

hope this picture helps show you all what I see


02-01-2014, 01:23 PM   #19
Senior Member




Join Date: Nov 2012
Location: Dundee Illinois
Photos: Gallery
Posts: 103
A couple of months ago I had a couple of spots on my sensor. I was able to blow the one on the upper left off with a Giotto but I could not budge the one on the lower left. I used a Pentax Imagesensor Cleaning Kit and it worked great. I was a little freaked touching my sensor with the wand but it worked as advertised.

Attached Images
View Picture EXIF
PENTAX K-30  Photo 
01-29-2015, 08:13 PM   #20
Forum Member




Join Date: Sep 2006
Location: Texas
Photos: Gallery | Albums
Posts: 59
I have had more dust issues with my K50 than any other Pentax body. My older K10 hardly ever gets dust, but the K50 seems to have problems and I am extremely careful about how I remove and add lens on the body too.
Other than that, I love my K50. Dust be gone!
01-30-2015, 08:02 AM   #21
csa
Loyal Site Supporter
csa's Avatar

Join Date: Aug 2014
Location: Montana mountains
Posts: 8,177
TomWil; thanks for retrieving the original post that started this thread, that was deleted. When coming to a thread a little late, and the opening post is deleted; it's a little confusing.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k50, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K50 etriggia Pentax K-30 & K-50 9 12-06-2013 08:03 AM
K50 Ad yesitismycoat Pentax K-30 & K-50 2 10-17-2013 03:48 AM
For Sale - Sold: K50 1.2 mills Sold Items 11 10-28-2012 11:06 AM
Cleaning mark on front element an issue? Deimos Troubleshooting and Beginner Help 22 04-19-2012 05:36 AM
Question about cleaning the DA* connector (with strongly concern of SDM issue) AirSupply Pentax SLR Lens Discussion 9 02-10-2010 09:52 AM



All times are GMT -7. The time now is 11:41 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top