Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-24-2014, 10:34 AM   #1
Senior Member




Join Date: Jan 2014
Posts: 143
Waranty? Help!!

So I've had my Pentax K-30 for maybe two months that I bought online off of BestBuy. I use my built in flash almost every day and I've never had any problems with it. Yesterday night I was bored shooting in my house with my new lens and I popped up the flash.

When I tried to take a photo the flash didn't discharge. In disbelief I tried again and still the flash didn't go off.. I tried one more time and the shutter did not open, and the camera turned off immediatly. It wouldn't turn back on until I took the battery out and put it back in. So I took some shots without flash. Everything was fine. I popped it back up tried to take a photo and again.. it turned off and didn't open the shutter..

I was curious so I got it back on again and changed the flash mode from normal to wireless just to see if anything was affected, and the camera did the same thing.. even though there was no flash attached or trigger or anything. It just shuts off....

I'm so bummed out and I did not buy the BestBuy camera waranty, but I know PENTAX has a 1 year waranty on all their cameras. I was going to order an off camera flash and triggers and a flash stand sometime this week but it seems that ANY type of flash WILL NOT work for some strange reason. NOTHING happend. I used my flash the night before It worked fine I don't understand!!

COULD SOMEONE HELP ME OUT???! I don't know what I should do about getting this fixed??! Would Best Buy fix it maybe? Or at least help me? Or do I have to contact PENTAX directly??

I did read through the waranty section in the manual I few times but it doesnt really give specific instructions on how to get a free repair.

01-24-2014, 10:53 AM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,770
Just a couple things to check first:
Battery fully charged? Charging the flash can drop the battery voltage below that required and shut the camera off, if the battery is close to drained. Try fully charging the battery and then re-test.
What shutter speed? The flash will not fire unless the shutter speed is lower than sync speed which I think is 1/180th on that camera.

Not sure what BB policy is, I read someplace 14 days no questions? You might contact them first. If not then it is warranty work for Pentax. If you are in USA then that is CRIS Camera.
01-24-2014, 07:58 PM   #3
Banned




Join Date: Feb 2013
Posts: 390
My guess is it's either a low battery, or a short in the internal electronics. My K30 will fire at 1/180 automatically if I try to set a faster speed.
01-24-2014, 11:52 PM   #4
Site Supporter




Join Date: Nov 2008
Location: Waikikamukau
Photos: Albums
Posts: 971
QuoteQuote:
but it seems that ANY type of flash WILL NOT work for some strange reason. NOTHING happend. I used my flash the night before It worked fine I don't understand!!
So you tried another flash on your Pentax ???
What brand and model was the flash you tried on the hotshoe..?

01-25-2014, 12:38 PM   #5
Veteran Member
FrankC's Avatar

Join Date: Dec 2011
Photos: Gallery
Posts: 318
If it ends up not being a battery or some other user error, then call BestBuy and see if you can exchange/return it at local store. BestBuy is usually pretty good about these sort of things and they might even have your sales record in their database.

Good luck
01-27-2014, 09:43 AM   #6
Loyal Site Supporter
narual's Avatar

Join Date: Jun 2013
Location: South Bend (Notre Dame), Indiana
Posts: 1,942
QuoteOriginally posted by bobD Quote
So you tried another flash on your Pentax ???
What brand and model was the flash you tried on the hotshoe..?
I think the OP means that changing flash modes didn't make a difference. Seems to only be using the built-in on-camera flash, since there was a mention of planning to order a flash.

But in case the OP is unaware -- never use old film flashes on a modern dslr without checking the voltage first (there's a chart on the forum here, somewhere). Some of them can zap your shiny new camera into a brick.
01-27-2014, 10:09 AM   #7
Senior Member




Join Date: Jan 2014
Posts: 143
Original Poster
QuoteOriginally posted by jatrax Quote
Just a couple things to check first:
Battery fully charged? Charging the flash can drop the battery voltage below that required and shut the camera off, if the battery is close to drained. Try fully charging the battery and then re-test.
What shutter speed? The flash will not fire unless the shutter speed is lower than sync speed which I think is 1/180th on that camera.

Not sure what BB policy is, I read someplace 14 days no questions? You might contact them first. If not then it is warranty work for Pentax. If you are in USA then that is CRIS Camera.
Battery was fully charged and the shutter speed will automatically drop under 180 when you pop up the flash, but thanks for the reply
01-27-2014, 10:11 AM   #8
Senior Member




Join Date: Jan 2014
Posts: 143
Original Poster
QuoteOriginally posted by bobD Quote
So you tried another flash on your Pentax ???
What brand and model was the flash you tried on the hotshoe..?
I didn't try another flash on the camera but I set it to wireless mode and when I shot it did the same as the built in flash and just shut the camera off

01-27-2014, 10:14 AM   #9
Senior Member




Join Date: Jan 2014
Posts: 143
Original Poster
Thanks for input guys. The flash started working again for some reason when I switched back to my kit lens. Then I tried again with my SMC A 135 and it works. I don't know what went wrong but it is working. Hopefully it doesnt happen again..
01-27-2014, 12:00 PM   #10
Inactive Account




Join Date: Mar 2007
Location: Long Island, N.Y.
Photos: Gallery
Posts: 1,124
Check and clean those contacts on the base of the "A" 135mm lens. I just had a similar situation while trying to get my old Super Program working again. Installed new batteries, camera seemed OK, went to use it and NO GO. After a while, I tried cleaning the contacts and wiggling the lens on the mount, and all was OK again. Communication between the lens and the camera must be good for things to work correctly.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
best buy, bestbuy, camera, flash, help, night, pentax, pentax help, pentax repair, photo, power, repair, waranty
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Extended Waranty Question...... BirdDude007 Pentax K-5 13 05-24-2013 04:48 AM
Help Help Please - lens stuck !! sujo78 Pentax K-30 & K-50 12 02-16-2013 11:26 PM
HELP! Moved from PC to MAC- need Lightroom and HD help jennverr Digital Processing, Software, and Printing 7 01-13-2013 12:53 PM
Waranty focus adjusted DA 40, need second opinions! the swede Pentax SLR Lens Discussion 3 02-05-2011 12:53 PM
No waranty/registration card Tom C Photographic Technique 3 03-25-2008 10:59 AM



All times are GMT -7. The time now is 10:51 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top