Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-10-2014, 06:11 AM   #1
New Member




Join Date: Feb 2014
Posts: 5
Pentax ME Super Shutter Won't Fire

Hello guys,tried to search my problem but didn't find the one related to my problem.
My dad gave me his old Pentax Me Super and I only started to finish 1 roll of film.After I wind the film and unloaded it from the camera,i tried to advanced the lever but when I pressed the shutter release button,the shutter won't fire.
I still can keep advancing the lever but the shutter just won't fire.Currently it appears that the mirror is down,first shutter curtain is closed but the second certain stayed open. I wonder if this problem can be repaired easily or just a matter or doing some tricks.

Thanks.

02-10-2014, 06:52 AM   #2
Veteran Member




Join Date: Feb 2010
Location: Kokubunji, Tokyo
Photos: Gallery
Posts: 458
Forgive me if this seems like an obvious and silly question, but you did check the battery right?

ME Super, unlike the fully manual MX, has an electronic shutter and it won't fire if the battery is dead.
02-10-2014, 07:37 AM   #3
New Member




Join Date: Feb 2014
Posts: 5
Original Poster
The battery was just new.The metering led blinks.Tried it on the mechanical mode 125x didn't work too.
02-10-2014, 08:25 AM   #4
Site Supporter




Join Date: Sep 2010
Posts: 456
I have one like that. There is something wrong in the cocking mechanism. It acts as though the rewind button is pressed. I binned mine as they are cheaper to replace than repair. I got mine with lenses and a Halliburton so I still came out ahead on the deal.

02-10-2014, 09:33 AM   #5
Veteran Member
blende8's Avatar

Join Date: Feb 2007
Location: Bremen, Germany
Photos: Albums
Posts: 1,484
QuoteOriginally posted by aoeu Quote
I have one like that. There is something wrong in the cocking mechanism. It acts as though the rewind button is pressed.
Same here.
This is a common problem with the ME super.
02-10-2014, 10:56 AM   #6
Loyal Site Supporter
AquaDome's Avatar

Join Date: Jan 2014
Location: New Carlisle, IN
Photos: Gallery | Albums
Posts: 1,397
I have two ME Super bodies with this or similar problem. Sometimes they wind, sometimes they don't. It seems like the wind lever is not engaging the shaft completely.
Have you tried using an auto-winder such as the ME-Winder or similar? They can be had for $10 or so on the ebay. The winder engages the shaft directly without using the top lever.
A working ME Super is a sweet little camera. Add a few A lenses and you're stylin' like a pro.
02-10-2014, 10:33 PM   #7
New Member




Join Date: Feb 2014
Posts: 5
Original Poster
So is it possible to fix it?or is it better to just buy a new one?
02-11-2014, 03:29 AM   #8
New Member




Join Date: Feb 2014
Posts: 5
Original Poster
Recently i advanced the lever again.Now the lever is loose,it doesn't crack the mechanism.Any suggestion?thanks

02-11-2014, 03:49 AM   #9
Site Supporter
arnold's Avatar

Join Date: Aug 2012
Location: Queensland
Photos: Gallery | Albums
Posts: 3,192
You can send it to Eric Hendrickson who specializes in these Pentaxes. Do a search on this forum for details. Might cost about $100 or so.
02-11-2014, 03:53 AM   #10
New Member




Join Date: Feb 2014
Posts: 5
Original Poster
I got the camera back to work again.Remove the bottom plate and i pushed some of the lever that was not enggaged.Now everything works fine.
Thank you everyone for you help.
02-11-2014, 09:13 AM   #11
Forum Member




Join Date: Feb 2009
Photos: Albums
Posts: 87
QuoteOriginally posted by aoeu Quote
I have one like that. There is something wrong in the cocking mechanism. It acts as though the rewind button is pressed. I binned mine as they are cheaper to replace than repair. I got mine with lenses and a Halliburton so I still came out ahead on the deal.
I did the exact same thing when mine did that. Wish I had kept the lens.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
fire, lever, me, pentax, pentax help, shutter, stuck, super
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Super A/Program Won't Fire: HELP richard balonglong Pentax Film SLR Discussion 10 12-30-2013 05:56 AM
ME Super - shutter doesn't fire iht Pentax Film SLR Discussion 13 09-12-2013 07:14 PM
Shutter won't fire anselesn Troubleshooting and Beginner Help 5 07-20-2013 04:30 PM
Super A / Super Program won't fire. Hamster Pentax Film SLR Discussion 2 07-28-2012 09:52 AM
ME Super winds on, but shutter won't cock ryan s Pentax Film SLR Discussion 7 04-20-2012 03:26 AM



All times are GMT -7. The time now is 07:24 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top