Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-13-2014, 11:52 AM   #1
New Member




Join Date: Feb 2014
Posts: 1
K1000 won't advance film

My K1000 stopped working halfway through a roll of film. It felt like it had come to the end of the film although I only used 18 or so frames. The advance lever won't pull across all the way and the shutter won't open when I press the button. The mirror on the inside of camera is down, so thats not the problem. I have since removed the film, tried it without any film inside, and even tried with a new roll. Nothing ever changes, and the lever stays the same. I need advice ASAP as I really need to use the camera this weekend!! Repairs might be expensive and would definitely take far too long. Please help!!!
Thank you in advance!

02-13-2014, 12:03 PM   #2
Pentaxian




Join Date: Sep 2008
Location: Phoenix, AZ
Posts: 1,434
I had this happen on my K1000 while at disneyland. It was a small screw in the advancing mechanism that came lose and locked everything up. it literally was a single screw.

Back in 1980 it cost ~100 to fix and took 10 minutes once the repair shop got around to fixing it. I'm not sure how much it would cost now, but unless you know how to repair cameras, you can't fix this by jamming or forcing anything. in fact you can only hurt the camera more.
02-13-2014, 03:27 PM   #3
Loyal Site Supporter
narual's Avatar

Join Date: Jun 2013
Location: South Bend (Notre Dame), Indiana
Posts: 1,942
Check on Craigslist. I see people selling used K1000 and other pentax film cameras pretty frequently. Local camera shop or junk/antique/thrift/goodwill/etc store may have some for sale, too
02-15-2014, 10:23 AM   #4
Veteran Member
FrankC's Avatar

Join Date: Dec 2011
Photos: Gallery
Posts: 318
I've seen this problem a lot in various brands and models. Sometimes the shutter gets jammed half way through the cocking process. If you open the back of the camera and can see the shutter curtain locked half way, that is, the metal frame to which the curtain is attached, then sometimes the shutter just needs to be flicked to get it unjammed. Very delicately I'd take the tip of my finger nail tug on the frame of the shutter curtain in the direction it normally travels, then quickly release it. Specifically, the part where the fabric is attached to a plastic or metal frame. Doing this a few times clears things up sometimes. Can't stress enough to be gentile.

If you don't see the black frame or edge of the curtain, then take your lens off, and with the mirror raised take your middle finger and thumb and tug on the curtain. So with your middle finger going into the front of the camera and your thumb at the back side of the shutter just gently pull in the normal travel direction of the shutter to get some tension and then release it. This typically fixes it.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advance, advance lever, advance won't move, camera, film, k1000, k1000 won't advance, lever, pentax help, roll, shutter button, stiff/stuck
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
pentax mg - film advance won't move past a certain spot hat.paradox Troubleshooting and Beginner Help 7 01-13-2014 10:34 PM
K1000 - Sluggish Film Advance severalsnakes Pentax Film SLR Discussion 4 01-04-2014 11:26 PM
K1000: Problem with film advance summernolan Troubleshooting and Beginner Help 7 04-14-2011 12:39 AM
Pentax K1000 film won't advance summernolan Troubleshooting and Beginner Help 2 03-04-2011 12:50 AM
K1000 mirror locks up with film advance awsutter Pentax Film SLR Discussion 4 12-27-2010 12:34 PM



All times are GMT -7. The time now is 07:33 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top