Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-04-2014, 08:36 PM   #1
New Member




Join Date: Mar 2014
Posts: 4
spotmatic shutter not firing

hi - new to pentax forums & pentax in general, i have used minolta up to this point but recently acquired a spotmatic which i like very much, although it has an issue: the indicator says that it's cocked, but the shutter isn't firing. is there a way to troubleshoot the shutter mechanism itself? or a lever i could trip to release it? i did try to set the self-timer a few times. the shutter seems to have free movement and moves at the end of the timer cycle but just isn't firing the curtain or clicking.

thanks for any help!

03-04-2014, 08:55 PM   #2
Pentaxian
arnold's Avatar

Join Date: Aug 2012
Location: Queensland
Photos: Gallery | Albums
Posts: 3,296
QuoteOriginally posted by punkrockpete Quote
hi - new to pentax forums & pentax in general, i have used minolta up to this point but recently acquired a spotmatic which i like very much, although it has an issue: the indicator says that it's cocked, but the shutter isn't firing. is there a way to troubleshoot the shutter mechanism itself? or a lever i could trip to release it? i did try to set the self-timer a few times. the shutter seems to have free movement and moves at the end of the timer cycle but just isn't firing the curtain or clicking.

thanks for any help!
Check out the Film SLR Camera section here. There is a link to a YouTube video I posted, where the bottom cover is opened. He shows how to apply lubrication.
03-04-2014, 09:08 PM   #3
New Member




Join Date: Mar 2014
Posts: 4
Original Poster
having trouble finding the link… can you post it here?
03-04-2014, 09:20 PM   #4
Pentaxian
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 13,898
Another thing to check is to make sure the film advance lever is fully cocked as far as it will go. My H2 shutter button was stuck until until another forum member suggested this tip.

03-04-2014, 09:26 PM   #5
New Member




Join Date: Mar 2014
Posts: 4
Original Poster
it feels like the lever has cocked it fully, total resistance. the red indicator reads cocked as well. the shutter moves up & down, just doesn't fire.
03-04-2014, 09:47 PM   #6
Pentaxian
arnold's Avatar

Join Date: Aug 2012
Location: Queensland
Photos: Gallery | Albums
Posts: 3,296
There should be a sticky on this, as I have had to look it up for several people.
03-04-2014, 09:48 PM   #7
Pentaxian
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 13,898
I believe this is the link arnold was referring to - it helped me resolve this problem with a Spotmatic II.
https://www.pentaxforums.com/forums/8-pentax-film-slr-discussion/236669-sp2-m...ml#post2505555

edit: arnold beat me to it! Agree - this should be a sticky.
03-05-2014, 08:29 PM   #8
New Member




Join Date: Mar 2014
Posts: 4
Original Poster
thanks very much!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
pentax, pentax help, shutter, spotmatic, spotmatic shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bronica SQAi shutter not firing. Kalki Pentax Film SLR Discussion 1 11-02-2013 06:42 AM
Af540 not firing, a curious beastie Mareket Flashes, Lighting, and Studio 4 12-05-2012 01:51 AM
z-1p issue with shutter firing. ckswong Troubleshooting and Beginner Help 3 06-30-2012 01:07 AM
Off-camera flash not firing molotschna Troubleshooting and Beginner Help 19 04-20-2012 02:46 PM
ME Super not firing correct shutter speeds mikengstrom Pentax Film SLR Discussion 5 07-25-2011 01:40 PM



All times are GMT -7. The time now is 01:25 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top