Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-28-2014, 09:54 AM   #1
New Member




Join Date: Mar 2014
Location: New York City
Posts: 3
AA Battery Pack FG on ZX-30: odd error

On a functional, well tested/used, ZX-30 a brand new AA Battery Pack FG works as billed when testing with no film in the camera and fresh duracells loaded. With film in the camera the battery pack opens the shutter when the release is pressed (I tried in both M mode at f8 & 1/125 and in Aperture Priority at f8 with the meter reading 1/125 and 1/250) and leaves it open for about 5 seconds. During this time the LCD display goes blank - no error. Ouch. When I remove the film, the grip/camera combo works fine. When I load CR2 lithium batteries into the camera after detaching the grip the camera works great. Unfortunately, the problem is easily replicated. Does anyone have any idea what is going on or what troubleshooting steps I can take?

03-28-2014, 10:21 AM   #2
Veteran Member




Join Date: Jul 2009
Location: London
Posts: 889
I'd make sure the electrical contacts are clean first.
03-28-2014, 10:27 AM   #3
New Member




Join Date: Mar 2014
Location: New York City
Posts: 3
Original Poster
Hi John, I did check this and everything looked good. I'll have at the contacts again with an eraser but I think something else is going on. Unfortunately I don't have a lot to go on.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aa battery pack fg, battery, battery pack fg, camera, error, f8, fg, film, pack, pentax help, shutter stuck, zx-30
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax AA Battery Pack FG Snarkomatic 2000 Sold Items 5 10-31-2009 06:32 AM
For Sale - Sold: Pentax 37000 AA Battery Pack FG (grip) for ZX/MZ cameras Brand New jjdgti Sold Items 8 08-07-2009 08:04 AM



All times are GMT -7. The time now is 05:24 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top