Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-29-2014, 07:29 AM   #1
Forum Member
Jake21209's Avatar

Join Date: May 2007
Location: Maryland
Posts: 81
Problem with my K5

I am having trouble with my K5. I did then download last week not problems there but have not used the camera until today. I have a new battery and card in the camera and after taking a shot the screen reads delete. When I go to look for the photo, there is nothing there. Does anyone else have this problem?

Jay

03-30-2014, 08:44 AM   #2
Veteran Member




Join Date: Oct 2008
Location: Frisco Texas
Photos: Gallery
Posts: 382
Have you tried a different SD card?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k5, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5 problem with shutter and lense adoupas Troubleshooting and Beginner Help 6 09-22-2013 03:31 PM
Pentax k5 problem with fully charged battery? sarahparish91 Pentax K-5 11 08-17-2013 09:26 AM
Focus problem with 18-55WR on K5 vlad2304 Pentax SLR Lens Discussion 12 11-04-2012 07:46 AM
K5 sent back for 'mirror slop' problem but came back with much worse problem captainbert Troubleshooting and Beginner Help 24 07-10-2012 01:08 PM
Help! Bizarre problem with my beloved K5! hsu1 Pentax K-5 7 12-26-2011 06:40 AM



All times are GMT -7. The time now is 10:53 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top