Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-30-2014, 04:36 PM   #1
New Member




Join Date: Mar 2014
Posts: 1
k100d

My camera will not turn on - it only shows a flashing battery on the display. I have changed batteries, and cleaned the contacts. Any other suggestions?

03-30-2014, 05:58 PM   #2
Pentaxian




Join Date: Apr 2007
Location: Oklahoma USA
Posts: 1,475
It's sensitive to battery quality - are you sure the batteries you changed to are good enough? After a while (a few years), my nimh batteries behave that way, even though the charger shows them to be fully charged. Nothing to do but replace them. If it won't work with fresh lithium AAs then I wouldn't know what to do.
03-30-2014, 07:13 PM   #3
Veteran Member
Julie's Avatar

Join Date: Aug 2010
Location: Illinois
Photos: Gallery | Albums
Posts: 1,067
Rechargeable batteries won't last forever, they can only be recharged so many times. Slowly, their capacity starts to dwindle, especially if they're a low capacity/cheap brand to begin with.

If you have any other rechargeable or any non-rechargeable batteries laying around, give those a try.

And may I suggest Sanyo Eneloops rechargeable batteries if you're looking for new ones- worked great with my istD, K-x, K-30 and my flashes.
03-31-2014, 01:07 PM   #4
Site Supporter
tomwil's Avatar

Join Date: May 2009
Location: Maryland USA
Posts: 778
QuoteOriginally posted by mimaf Quote
My camera will not turn on - it only shows a flashing battery on the display. I have changed batteries, and cleaned the contacts. Any other suggestions?
The problem and solution is explained in this thread:

https://www.pentaxforums.com/forums/6-pentax-dslr-discussion/13335-ist-dl-batteries.html

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K100d not working Jimmy Troubleshooting and Beginner Help 16 01-13-2014 04:12 AM



All times are GMT -7. The time now is 01:48 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top