Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-15-2014, 10:34 AM   #1
Site Supporter




Join Date: Apr 2009
Location: Ireland
Posts: 269
K7 ISO Settings Problem

Hi,

Yesterday I upgraded from a K200D which I bought in 2008 to a secondhand K7, yes I know, time moves slowly around here.

The body seems fine with only 5000 shutter actuations.

According to the printed manual accompanying the K7 and the chart at the top of the camera review page here, base ISO is given as 100, try as I might, including reading the manual, I cannot get the setting to go below 200, the higher end figures show up OK.

Is there something else I should be doing or is this a common problem or has some firmware review changed the parameters.

I have 10 days on approval.

Thanks in advance.

CD

04-15-2014, 10:51 AM   #2
Inactive Account




Join Date: Jul 2010
Photos: Gallery
Posts: 328
The normal range is from 200 you have to go into the setup menu and turn on the Expanded range.
04-15-2014, 11:06 AM   #3
Site Supporter




Join Date: Apr 2009
Location: Ireland
Posts: 269
Original Poster
QuoteOriginally posted by bobpur Quote
The normal range is from 200 you have to go into the setup menu and turn on the Expanded range.
Thank you, I will do that as soon as the battery finishes charging.

CD
04-15-2014, 11:16 AM   #4
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 4,846
There is another setting to check. In the [Rec. Mode 1] menu, under [D-Range Setting], make sure to uncheck the [Highlight Correction] box. There's a note on this in the manual, page 200.

04-15-2014, 03:30 PM   #5
Site Supporter




Join Date: Apr 2009
Location: Ireland
Posts: 269
Original Poster
QuoteOriginally posted by Just1MoreDave Quote
There is another setting to check. In the [Rec. Mode 1] menu, under [D-Range Setting], make sure to uncheck the [Highlight Correction] box. There's a note on this in the manual, page 200.
I noticed that as soon as I unchecked the Highlight Correction Box there was more flexibility in the ISO settings and I have checked the Expand Sensitivity and am now in business, it was the only thing that as far as I could see was not working properly.

Thank you both very much.

CD
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
iso, k7, k7 iso settings, pentax help, review
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why no low ISO settings? GibbyTheMole Pentax DSLR Discussion 13 06-29-2013 03:45 AM
Manual Lens Iso Settings chucuyuco Pentax K-01 3 03-06-2013 05:07 PM
High ISO settings for K-01 raider Pentax K-01 10 12-03-2012 09:18 PM
High ISO noise reduction settings? Dewman Digital Processing, Software, and Printing 4 05-30-2012 05:13 AM
k7 iso problem? reynb Pentax DSLR Discussion 2 12-15-2009 04:15 AM



All times are GMT -7. The time now is 06:49 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top