Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-18-2014, 12:32 PM   #1
New Member




Join Date: Apr 2013
Photos: Albums
Posts: 19
K-r, mirror is not going up, no Live View either

Hi everyone,

just before holiday trip my K-r got broken. Wonder if this can be fixed at home or I have to search for camera specialist.

Symptoms are as following:
- When I press on shutter button there is a sound like internals are trying to adjust aperture and raise the mirror, but nothing actually happens.
- When I go to Live View mode, the same sound but nothing happens, mirror is not up.
- When I use Sensor Cleaning Mirror Up feature, nothing happens too.
- This is constant behaviour and does not depend on a lens attached. The same happens also without a lens.
- Some time ago K-r started to do mirror flopping with old K/M lenses, so it seems related also given K-r got broken having M135 lense attached.

Any ideas what is this? :|

See video here:


04-19-2014, 06:58 PM   #2
Veteran Member




Join Date: Feb 2012
Posts: 456
QuoteOriginally posted by d1pr3d Quote
Hi everyone,

just before holiday trip my K-r got broken. Wonder if this can be fixed at home or I have to search for camera specialist.

Symptoms are as following:
- When I press on shutter button there is a sound like internals are trying to adjust aperture and raise the mirror, but nothing actually happens.
- When I go to Live View mode, the same sound but nothing happens, mirror is not up.
- When I use Sensor Cleaning Mirror Up feature, nothing happens too.
- This is constant behaviour and does not depend on a lens attached. The same happens also without a lens.
- Some time ago K-r started to do mirror flopping with old K/M lenses, so it seems related also given K-r got broken having M135 lense attached.

Any ideas what is this? :|

See video here: Pentax K-r mirror/shutter issue - YouTube
"Broken" is too vague a designation. Did you drop it on the ground? This is the strangest sound I have ever heard come out of a camera. Although I doubt that I can help you, I would still be interested in knowing how this problem occured, considering that I myself am a mostly happy owner of the Kr.

If you didn't drop it, reset the camera, reinstall everything, and make sure that you have the latest needed firmware.

Last edited by DominicVII; 04-19-2014 at 07:11 PM.
04-20-2014, 12:22 AM   #3
New Member




Join Date: Apr 2013
Photos: Albums
Posts: 19
Original Poster
I am happy K-r owner for 3 years and 35k actuations already. Even had no plans to change it.
It just happened while shooting in a field, no drops, no hits, nothing. Just switched to this behaviour. As I mentioned, there was "mirror flopping" issue before with K/M lenses and this time I had M135 on.

I will be in London next week and will try to bring it to specialist (it is not that easy to find one here where I am in the middle of nowhere during global Easter holidays
Thus will post back if will get any valid answer.

Thanks anyway. Might be worth update firmware, hm..
04-20-2014, 12:10 PM   #4
Site Supporter




Join Date: Nov 2012
Location: North Wales
Photos: Gallery | Albums
Posts: 1,544
If you need parts I have a K-r body expressly purchased for use as spare parts (I need the mirror and the casing)

04-20-2014, 12:18 PM   #5
New Member




Join Date: Apr 2013
Photos: Albums
Posts: 19
Original Poster
QuoteOriginally posted by marcusBMG Quote
If you need parts I have a K-r body expressly purchased for use as spare parts (I need the mirror and the casing)
Thanks Marcus, will keep in mind.
12-19-2016, 08:27 AM   #6
New Member




Join Date: Dec 2016
Posts: 2
Same problem with k20d

I have almost the same problem, the noise is exactly the same just that my camera is working really really slow. I didn't drop it or something it just stopped working.

Did you figure out a easy fix?

Thank you.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
attached, k-r, lens, live, mirror, mirror issue, pentax help, shutter, sound, view
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Locking the mirror during Live view shooting mtux Pentax DSLR Discussion 20 03-06-2015 10:45 PM
Live View-Mirror Position Den Pentax K-5 3 09-30-2013 06:38 AM
Macro No it's not here either! eaglem Post Your Photos! 4 07-05-2013 07:16 AM
K-r : Live View focus, AF & manual madbrain Pentax DSLR Discussion 6 06-02-2012 11:55 PM
Problem with k-r live view eldela1590 Pentax K-r 2 07-28-2011 12:45 AM



All times are GMT -7. The time now is 08:00 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top