Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-06-2014, 07:54 PM   #1
New Member




Join Date: May 2014
Posts: 4
crazy shutter behavior

After enjoying my k10 for a couple of years I decided to try some new things with the help of the manual. I had also refreshed the battery charge today. Unfortunately the camera has gone mad and the shutter keeps clicking, this happens no matter which button I touch or even when I tilt the body holding only the frame. I took the battery out and replaced, this fixed it for two frames and then it started again. Thoughts?

05-06-2014, 08:49 PM   #2
Pentaxian
calsan's Avatar

Join Date: Nov 2008
Location: Perth, Australia
Photos: Gallery
Posts: 1,387
It might be the battery is now old and can't supply the correct minimum voltage...
Can you try another battery?
05-06-2014, 09:25 PM   #3
New Member




Join Date: May 2014
Posts: 4
Original Poster
thank you for that thought. i did switch to the back up battery which was just charged as well, but, they are both about the same age / use to date so I will borrow one tomorrow and see if that might be it.
05-06-2014, 11:26 PM   #4
Pentaxian
calsan's Avatar

Join Date: Nov 2008
Location: Perth, Australia
Photos: Gallery
Posts: 1,387
Fingers crossed.

05-07-2014, 03:54 AM   #5
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
Not to want to put a real scare into you, but my *istD did this when it got swamped in a kayak until I dried it out thoroughly.

If we follow the battery issue , what does the battery indication do whine this behaviour is taking place?
05-07-2014, 05:48 AM   #6
New Member




Join Date: May 2014
Posts: 4
Original Poster
the battery actually shows full. mmmmm. i haven't been very damp though a couple of days ago i was shooting in a light rain without the camera 'raincoat' with me i had a plastic bag over the lens. it is possible it may have gotten some moisture. thank you for your feedback.
05-09-2014, 04:35 AM   #7
New Member




Join Date: May 2014
Posts: 2
Hi, Very likely to be batteries. My K200 did a similar thing with the shutter when I used rechargeable batteries, sometimes they were tired sometimes not, usually showed a full battery symbol. The only way to stop it was to take the batteries out. I only use Lithium now.
05-11-2014, 08:22 AM   #8
New Member




Join Date: May 2014
Posts: 4
Original Poster
thank you each for your thoughts, for equally unknown reasons to its crazy behavior, a buddy fixed it. He has no idea what he did other than in menu checking shutter speed, going into a second level screen and suddenly it stopped. mmmmmm. hopefully never to return! but, if it does I think I will just treat it to a nice new battery!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, pentax help, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-r Crazy Shutter K David Troubleshooting and Beginner Help 7 10-27-2014 01:29 PM
K5 mirror/shutter behavior grog13 Pentax K-5 5 12-24-2012 08:02 PM
Strange lens behavior slip Troubleshooting and Beginner Help 4 10-09-2012 05:28 PM
645D Erratic Dial Behavior CrisMitchell Pentax Medium Format 3 10-01-2012 12:31 AM
K200D shutter gone crazy Steve B Visitors' Center 3 06-11-2012 11:22 AM



All times are GMT -7. The time now is 02:37 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top