Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-09-2014, 10:54 PM   #1
New Member




Join Date: Jul 2014
Posts: 4
Problem with Pentax DA 16-50 F2.8 lens on K3

I bought DA 16050 F2.8 lens when I had a K20D. It worked fine.
I've new bought a K3 and it will only work on manual focus. On auto focus it locks up the camera. Other lens work fine and I tried it again on my K20D and it worked fine again.
Help please?

Ian

07-10-2014, 12:30 AM   #2
Site Supporter
AussieTrev's Avatar

Join Date: Jul 2010
Location: Queensland
Photos: Gallery | Albums
Posts: 3,077
Might need a service call. I have that combo and it is fine, my regular lens.
07-10-2014, 03:03 AM   #3
Site Supporter
Sandy Hancock's Avatar

Join Date: Feb 2012
Location: Adelaide Hills, South Australia
Photos: Gallery | Albums
Posts: 5,249
Do you have another SDM-enabled body to test it on? If the SDM is dead you could convert it to screw drive; I did, and will never look back.
My other SDM lenses are just fine on my K-3, so I don't think it's the camera.
07-10-2014, 04:10 AM   #4
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,331
QuoteOriginally posted by ifegent Quote
On auto focus it locks up the camera.
Can you describe this in detail?
You have the lens on the camera, you turn the camera on.. then what?
Also, please make sure your batteries are fully charged and you are using the latest firmware on your camera.

07-10-2014, 04:12 AM   #5
New Member




Join Date: Jul 2014
Posts: 4
Original Poster
Convert to screw drive? how do you do that?

Ian
07-10-2014, 04:25 AM   #6
Site Supporter
Sandy Hancock's Avatar

Join Date: Feb 2012
Location: Adelaide Hills, South Australia
Photos: Gallery | Albums
Posts: 5,249
QuoteOriginally posted by ifegent Quote
Convert to screw drive? how do you do that?
Like THIS.
07-10-2014, 04:25 AM   #7
New Member




Join Date: Jul 2014
Posts: 4
Original Poster
QuoteOriginally posted by Na Horuk Quote
Can you describe this in detail?
You have the lens on the camera, you turn the camera on.. then what?
Also, please make sure your batteries are fully charged and you are using the latest firmware on your camera.
If I have the camera and lens on auto focus the focus symbol in the view finder flashes when I half depress the shutter and nothing happens. I can't fully depress the shutter button to take a photo. My battery is fully charged. I'll check the firmware.

Thanks
Ian
07-10-2014, 05:31 AM   #8
Site Supporter
Sandy Hancock's Avatar

Join Date: Feb 2012
Location: Adelaide Hills, South Australia
Photos: Gallery | Albums
Posts: 5,249
It sounds like your SDM is dead, and with the camera set to focus priority the shutter will not fire. This happened to both of my DA*16-50's
You either need to get the lens repaired (which I did with one, and then sold it) or hack it into screw drive (which I did to the one I still have).

07-10-2014, 07:16 AM   #9
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,216
QuoteOriginally posted by Sandy Hancock Quote
Do you have another SDM-enabled body to test it on?
I think the OP stated that the lens continues to work fine on their K20D (SDM body), so it would appear that the SDM is not dead. Conversion to screw mount might not hurt, but may not help either. I believe the process is irreversible, no? Other lenses work fine on the K-3, but it is not clear whether those lenses are SDM or screw mount. Since the K-3 is still under warranty, I believe that Ricoh/Pentax support might be the best option at this point.


Steve
07-10-2014, 05:05 PM   #10
New Member




Join Date: Jul 2014
Posts: 4
Original Poster
QuoteOriginally posted by Na Horuk Quote
Can you describe this in detail?
You have the lens on the camera, you turn the camera on.. then what?
Also, please make sure your batteries are fully charged and you are using the latest firmware on your camera.
Thanks Na
I updated the firmware and hey presto! It now works.
Great relief as I'm heading to Europe for 10 weeks next week.

Ian
07-10-2014, 05:34 PM   #11
Pentaxian
RobA_Oz's Avatar

Join Date: Nov 2008
Location: Tasmania, Australia
Photos: Gallery
Posts: 4,125
QuoteOriginally posted by stevebrot Quote
I think the OP stated that the lens continues to work fine on their K20D (SDM body), so it would appear that the SDM is not dead. Conversion to screw mount might not hurt, but may not help either. I believe the process is irreversible, no? Other lenses work fine on the K-3, but it is not clear whether those lenses are SDM or screw mount. Since the K-3 is still under warranty, I believe that Ricoh/Pentax support might be the best option at this point.


Steve
The screw mount conversion is done in lens firmware, so it is reversible, assuming of course that a glitch in uploading doesn't brick anything (I haven't heard of this happening, btw). After a couple of years of frustration with my DA*16-50, I converted mine and, while the extra focussing noise is noticeable to me, it hasn't been a problem and it's certainly faster than SDM was on my K20D, K-5 and K-3, but that just might have been the drive slowly clagging up.
07-10-2014, 07:58 PM   #12
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,216
QuoteOriginally posted by RobA_Oz Quote
The screw mount conversion is done in lens firmware, so it is reversible
I am familiar with how it is done, but don't remember a step where the existing firmware is saved off.


Steve
07-13-2014, 06:29 AM   #13
Pentaxian
RobA_Oz's Avatar

Join Date: Nov 2008
Location: Tasmania, Australia
Photos: Gallery
Posts: 4,125
QuoteOriginally posted by stevebrot Quote
I am familiar with how it is done, but don't remember a step where the existing firmware is saved off.


Steve
From recollection, it is a lookup table that is changed and there was a step to save the original configuration as a text file.
07-14-2014, 11:48 AM   #14
Inactive Account




Join Date: Jan 2014
Posts: 11
QuoteOriginally posted by ifegent Quote
I bought DA 16050 F2.8 lens when I had a K20D. It worked fine.
I've new bought a K3 and it will only work on manual focus. On auto focus it locks up the camera. Other lens work fine and I tried it again on my K20D and it worked fine again.
Help please?

Ian
Ian. I'm experiencing the same. Are you using the same memory card in the K-3 and the K20D?

I'm going to try a different memory card as i think it might be the problem...??
07-14-2014, 10:13 PM   #15
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,587
QuoteOriginally posted by ifegent Quote
I updated the firmware and hey presto! It now works.
This is interesting.

The firmware update either did something clever:
- directly (eg to the way SDM lenses are handled), or
- indirectly (perhaps the process of updating the firmware reset to the defaults some of the camera custom settings for focus priority AF etc that were causing the OP's original problems).
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
da, da 16-50 f2.8, f2.8, f2.8 lens, focus, k20d, k3, lens, lens problems, pentax da, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Verdict on latest revision of DA* 16-50 f2.8? cbope Pentax SLR Lens Discussion 34 03-23-2014 08:32 AM
For Sale - Sold: DA* 16-50 f2.8 with ~6 months guarantee hoanpham Sold Items 8 12-04-2013 01:25 PM
Pentax 16-50 DA* F2.8 and 50-135 DA* F2.8 - what's the best way to use them ? Foma2 Pentax SLR Lens Discussion 15 09-15-2013 01:23 AM
For Sale - Sold: Pentax DA 16-50mm F2.8+ DA 50-135mm F2.8+DA 55mm F1.4 +AF540 flash ljay1129 Sold Items 4 11-25-2012 12:34 AM
For Sale - Sold: Pentax DA* 16-50 f2.8 lens kent vinyard Sold Items 2 10-21-2008 11:25 AM



All times are GMT -7. The time now is 03:27 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top