Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-16-2014, 03:07 AM   #1
Forum Member




Join Date: Aug 2011
Location: sunderland tyne and wear
Posts: 75
pictures taking much longer to show up on my camera

Hello everone I just bought a new lens its the smc da 1:2.4 35mm al it takes great picture but it takes a long time to show the pictures up on the back of my camera my camera is a pentax k5 any advice if I need 2 set my camera u different thanks in advance


Last edited by safc; 07-16-2014 at 03:15 AM.
07-16-2014, 03:21 AM   #2
Pentaxian




Join Date: Nov 2013
Location: North Bohemia
Photos: Gallery
Posts: 1,145
what a SD card do you use? It may be slow card.
07-16-2014, 03:21 AM   #3
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 6,552
Using a different Pentax lens should not affect the time it takes for a photo to show up on the LCD screen. Suggest you remove the battery and re-insert and see if that fixes the problem.
07-16-2014, 03:30 AM   #4
Forum Member




Join Date: Aug 2011
Location: sunderland tyne and wear
Posts: 75
Original Poster
QuoteOriginally posted by MarkJerling Quote
Using a different Pentax lens should not affect the time it takes for a photo to show up on the LCD screen. Suggest you remove the battery and re-insert and see if that fixes the problem.
I"ve done that and even reset my camera to factory set but its still the same and I"ve got a couple of memory cards what work fine with my other lenses could they be some sort of fault with the lens?

07-16-2014, 04:01 AM   #5
Pentaxian




Join Date: Nov 2013
Location: North Bohemia
Photos: Gallery
Posts: 1,145
QuoteOriginally posted by safc Quote
I"ve done that and even reset my camera to factory set but its still the same and I"ve got a couple of memory cards what work fine with my other lenses could they be some sort of fault with the lens?
I haven't encountered this but...have you have the lens corrections enabled ?
07-16-2014, 04:14 AM   #6
Forum Member




Join Date: Aug 2011
Location: sunderland tyne and wear
Posts: 75
Original Poster
QuoteOriginally posted by AldaCZ Quote
I haven't encountered this but...have you have the lens corrections enabled ?
Cheers for that aldacz you right it was enabled thanks to you all for your advice I do appreciate all your help

Last edited by safc; 07-16-2014 at 04:25 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, cards, couple, lens, lenses, memory, pentax help, pentax lens, pictures
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
images taking time to show on LCD in manual modes atg Pentax K-5 3 01-21-2014 12:43 PM
Back up sd card pictures to Android phone on the field? lightbulb Troubleshooting and Beginner Help 9 06-24-2013 12:22 AM
K-R Locks up in bulb mode on longer shots jostafew Troubleshooting and Beginner Help 3 09-08-2012 10:59 AM
Advice for setting up a website to show my pictures? Krzys Photographic Industry and Professionals 16 12-31-2011 10:01 AM
Macro snail taking up residence on my hosta plant fevbusch Post Your Photos! 10 07-05-2011 05:18 AM



All times are GMT -7. The time now is 07:15 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top