Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-25-2014, 04:54 AM   #1
Forum Member




Join Date: Feb 2014
Photos: Gallery | Albums
Posts: 50
K5ii SD card problem

I have been reading some k5 SD card problems but no solving, and never find any issue with the K5ii.

Last Sunday I used my K5ii under a rainy day, worked perfect as spected, removed SD card to import them into computer as usual, and back into camera, but now 4 days later, trying to use my camera everything works perfect, it does not want to read any SD card. I have a k01 and tryed all SD cards and they works, so no problems with them.

I'm desperating, any idea.?

07-25-2014, 06:14 AM   #2
Site Supporter
Rnovo's Avatar

Join Date: Mar 2008
Location: Mahone Bay, NS, Canada
Photos: Gallery | Albums
Posts: 264
...take the battery out, wait for 3 minutes or more and put another one in, fully charged...?
07-25-2014, 01:51 PM   #3
Forum Member




Join Date: Feb 2014
Photos: Gallery | Albums
Posts: 50
Original Poster
Done !! but no change, I stil get same error. . . Im updaloding a video.
07-25-2014, 02:24 PM   #4
Moderator
Site Supporter
photolady95's Avatar

Join Date: May 2009
Location: Cruising PentaxForums and watching your back.
Photos: Gallery | Albums
Posts: 8,908
Did you try another SD card in the K5ll? What is the error message you get? Which brand is the SD card that's getting the error message and how old is it?

07-25-2014, 02:39 PM   #5
Forum Member




Join Date: Feb 2014
Photos: Gallery | Albums
Posts: 50
Original Poster
Here is the video !!


I used same cards in a pentax k01 and they works fine.
07-25-2014, 03:00 PM   #6
Site Supporter
Mallee Boy's Avatar

Join Date: Sep 2006
Location: Hindmarsh Isl. Sth Australia
Photos: Gallery | Albums
Posts: 3,485
Mystery. Have you tried re-setting the camera to factory defaults?
07-25-2014, 03:16 PM   #7
Forum Member




Join Date: Feb 2014
Photos: Gallery | Albums
Posts: 50
Original Poster
Yes !! Tried too, but does not work. And I have a wedding in 15 days.
07-25-2014, 04:27 PM   #8
Moderator
Site Supporter
photolady95's Avatar

Join Date: May 2009
Location: Cruising PentaxForums and watching your back.
Photos: Gallery | Albums
Posts: 8,908
I just watched the video and saw how you removed the card from the box you store them in. You touched the pins on the card, ugh! Fingers have oil on them, and it's not a good idea to touch them to your card/s pins. Try a pencil eraser on the pins, carefully run it across the pins, then use a brush to brush off the pins, and remove the rubbers debris.

07-25-2014, 10:36 PM   #9
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,915
Obviously the camera don't read the cards. As you've eliminated the cards as the problem, the problem should be with the camera. It's possible that the problem might be with the card contacts inside the camera, in your place I would try spraying the contacts with a little switch cleaner, one way or another the contacts might've gotten some dirt on them. You can't actually loose anything, because you'll probably have to send it in for repairs, if that doesn't work. I've used switch cleaner in the past on my K-x with sticky shutter button and lens release button, without any problem, and the K-x don't have weather sealing like the K-5...

Last edited by altopiet; 07-25-2014 at 10:42 PM.
07-26-2014, 06:48 AM   #10
Forum Member




Join Date: Feb 2014
Photos: Gallery | Albums
Posts: 50
Original Poster
Im worried about get some sprays inside card slot . Im thinking about a few days ago , I was trying to force a damaged card, with some plastic broken.





Maybe , any contact is twisted
07-26-2014, 03:21 PM   #11
Forum Member




Join Date: Feb 2014
Photos: Gallery | Albums
Posts: 50
Original Poster
PROBLEM FOUND !!!

A friend of mine, bring a k5iis for comparing sd card slot pins, and we found two pins missing, I think they was broked with that delkin card . . .



as seen in picture, fourth and sixth pin are missing.
Attached Images
 
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, k5ii, k5ii sd card, pentax help, sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
optio S50 problem when I put in SD card carzey3 Troubleshooting and Beginner Help 2 06-09-2014 11:08 AM
For Sale - Sold: Pentax K-5 II * 32GB SD card * K5II REDUCED transam879 Sold Items 5 03-03-2014 09:26 PM
Problem Formating SD card X-Raycer Troubleshooting and Beginner Help 11 07-20-2013 12:33 PM
Problem with SD Card and *ist DL sailor1942 Troubleshooting and Beginner Help 3 03-25-2013 03:35 PM
SD Card Problem dogbear1980 Pentax DSLR Discussion 5 01-09-2010 05:29 PM



All times are GMT -7. The time now is 01:26 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top