Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-26-2014, 07:20 AM   #1
Pentaxian
fgaudet's Avatar

Join Date: Oct 2013
Location: Ontario
Posts: 726
K3 EXIF always reporting Manual focus

So here it is, I never noticed before since I'm always bouncing back and forth between AF and MF and I rarely bother checking the EXIF in my pictures. Because of this it is hard to know when it started happening so I will assume that it has been this way since Day One. My K3 is running FW 1.03 since I got it.

Now the funny thing, the EXIF of every picture I took with the K3 reports "Manual Focus" regardless of the focussing mode, regardless of the shooting mode (M,Av,Tv,P) and regardless of the lens (tried with 7 different lenses, from 4 different makes).

And as a bonus, I rarely use the popup flash but I remember clearly trying it out but I cannot find any pictures in my library taken with the K3 that the EXIF reports that the flash was used?!

Just to make sure it wasn't just Aperture that read the EXIF wrong, I double checked with LR... Manual Focus, always...

It's no big deal since asides from the focus mode and "maybe" the flash mode, everything else is reported correctly.

Anyone else has this happens?

07-26-2014, 07:34 AM   #2
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,455
I don't have time to research my K-3 images right now, but are you sure that the maker notes for the K-3 include AF or AF mode? If so, I would lay my suspicions on Aperture.


Steve
07-26-2014, 08:36 AM   #3
Pentaxian
fgaudet's Avatar

Join Date: Oct 2013
Location: Ontario
Posts: 726
Original Poster
QuoteOriginally posted by stevebrot Quote
but are you sure that the maker notes for the K-3 include AF or AF mode? If so, I would lay my suspicions on Aperture.
It probably is Aperture. I forgot to mention that I am shooting RAW, if I shoot JPG, the focus data doesn't get filled up in EXIF by the camera (shows blank in aperture).

It bugs me because in Aperture all my images from my Kr, K7, K5 do report the focus mode correctly.

Looking at the RAW data from the K3 DNG in photoshop also doesn't show anything relating to focus. My K5 is out on loan, the Kr is gone and the K7 is at work... so I cannot check to see if it does indeed report focus mode in the unaltered RAW file for my other cameras...
Attached Images
   
07-26-2014, 10:42 AM   #4
Veteran Member
OregonJim's Avatar

Join Date: Mar 2009
Location: Willamette Valley, Oregon
Posts: 1,329
QuoteOriginally posted by fgaudet Quote
Just to make sure it wasn't just Aperture that read the EXIF wrong, I double checked with LR... Manual Focus, always...
Well, the EXIF data from the K-3 is fine. It took me awhile to find images with AF enabled (I shoot 99% MF), but here is the pertinent data from both FW 1.03 and 1.10 using exiftool:

Make : RICOH IMAGING COMPANY, LTD.
Camera Model Name : PENTAX K-3
Software : PENTAX K-3 Ver. 1.03
Focus Mode : AF-C (Focus-priority)
AF Point Selected : Center; 0
DSP Firmware Version : 1.03.23.13
Lens Type : smc PENTAX-FA 28-80mm F3.5-5.6
Manufacture Date : 2013:12:11
Production Code : 2.1


Make : RICOH IMAGING COMPANY, LTD.
Camera Model Name : PENTAX K-3
Software : PENTAX K-3 Ver. 1.10
Focus Mode : AF-C (Focus-priority)
AF Point Selected : Center; 0
DSP Firmware Version : 1.10.26.15
Lens Type : smc PENTAX-DA 35mm F2.4 AL
Manufacture Date : 2013:12:11
Production Code : 2.1

07-26-2014, 11:23 AM   #5
Pentaxian
fgaudet's Avatar

Join Date: Oct 2013
Location: Ontario
Posts: 726
Original Poster
I did some more homework and as long as the DNG don't get near Aperture, the EXIF is OK. If I import the DNG to Aperture, then export the original (in TIFF) the EXIF remains ok BUT if I export to JPEG... Magically it becomes Manual... But no matter what format, Aperture always reports Manual.

So it sure looks like an Aperture problem... Probably related to the difficulty Apple had to implement the K3 RAW file support.

Minor annoyance I guess, I can easily live with this but it makes you wonder what else they got wrong with reading the RAW file...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
exif, flash, focus, k3, mode, pentax help, pictures, reports
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3 Jpeg EXIF Data is missing values unkipunki Pentax K-3 9 11-14-2013 03:22 AM
K3 Manual available dave kitson Pentax News and Rumors 32 10-29-2013 01:26 AM
Question about focus lock indicator on manual focus lens jostafew Pentax K-r 6 07-24-2013 10:50 AM
Bell Labs creates a lensless camera that's always in focus interested_observer Photographic Industry and Professionals 8 06-05-2013 11:11 AM
Manual Lens EXIF Information interested_observer Pentax SLR Lens Discussion 15 01-05-2013 03:08 AM



All times are GMT -7. The time now is 10:23 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top