Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-29-2014, 11:06 AM   #1
Senior Member




Join Date: May 2014
Posts: 115
K30 quit working

The other day while shooting my son's football practice my K30 went all crazy and then quit working properly. It made this horrible clicking shutter noise and then froze. I had to remove the battery to get it to completely turn off as just turning the power off did not work. I turned it back on and attempted to shoot another shot, in sports mode, and it just made that awful clicking shutter noise and maybe 10 seconds later took the shot. When I got home I made sure the lens was seated properly and functioning, that was fine. I removed the lens to check the shutter function and bingo, there was that awful clicking shutter noise and a serious delay in taking of the shot. I contacted Pentax about the issue and they said it sounds like a shutter/mirror function issue and want me to send it in. However, as they are moving, they cannot accept equipment to work on until after August 8. What I am wondering is if anyone else has had this issue and what was your fix? If anything I'd like to know what this will cost me on average. My KX and K20d are being serviced and cleaned right now so I am in a real pickle as these are all used as professional cameras.

07-29-2014, 11:22 AM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,749
There are a number of "mirror flapping" issues, not all quite the same. And mostly with the k-5 and some with the k-3. Not a huge number of complaints with the k-30 that I remember seeing.

Anyway, you have done all that is recommended, except perhaps try a different battery. So it will need to go in for repair. My k-5 went in for a similar issue (they called it mirror overrun) and was repaired under warranty so no idea of the cost.

Lousy timing as they have announced they are changing repair centers and CRIS will no longer be doing the warranty service. If it is out of warranty you might talk to CRIS and see if they are still accepting Pentax just not warranty. Not sure what the status will be as the notice on the website was a little unclear.
07-29-2014, 11:54 AM   #3
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,294
QuoteOriginally posted by jatrax Quote
Not a huge number of complaints with the k-30 that I remember seeing.
Yep...The K-30 has led a charmed life. It sounds like you have done your due diligence and the service center is your best bet.


Steve
07-29-2014, 12:23 PM   #4
Senior Member




Join Date: May 2014
Posts: 115
Original Poster
Figures I'm the one who runs a K30 into the ground.

07-29-2014, 12:53 PM   #5
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,749
This thread might be of interest: https://www.pentaxforums.com/forums/16-pentax-news-rumors/269090-repairs.html
07-31-2014, 09:50 AM   #6
New Member




Join Date: Jul 2014
Posts: 8
try clean the ring-shaped part of the camera where the lense is attached, do the same for the lense. It worked for my Kr. Be careful to do that with camera facing down.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
broke, fix, function, issue, issues, k30, lens, noise, pentax help, shot, shutter, shutter actuations
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K30 pop up flash stopped working? stillshot2 Pentax K-30 & K-50 20 03-12-2014 08:23 AM
K 01 Video shake reduction quit working dflorez Troubleshooting and Beginner Help 1 06-22-2013 09:03 AM
flash quit working trevorgrout Flashes, Lighting, and Studio 0 10-03-2012 04:57 PM
AF-360fgz quit working... Mopos Flashes, Lighting, and Studio 3 12-27-2011 10:47 AM
Pentax K100D Preview display in LCD quit working. mysharonna Troubleshooting and Beginner Help 9 11-23-2009 06:46 PM



All times are GMT -7. The time now is 03:15 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top