Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-30-2014, 02:49 PM   #1
Pentaxian
8540tomg's Avatar

Join Date: Feb 2008
Location: Waterloo, Ontario
Photos: Gallery
Posts: 4,454
K10D ISO question

Hi all,

I just noticed something odd in the LCD panel on the top of my K10. In the lower right quadrant I normally used to see the ISO setting. For some reason I have a number showing which seems unrelated to ISO. It is counting backwards from 827, one shot at a time as I trip the shutter. I have set the ISO to 100 and taken a few shots. The images are properly exposed and show ISO 100 in the EXIF but the 827 number returns and starts counting down again. I don't see anything in the K10 Operating Manual regarding this issue.

Here are the steps I've taken so far:

I have deleted all images on the card and reformatted it.

I removed the card and rebooted the camera. I turned it off, reinserted the card and turned it on again. It's the old turn it off and on again trick that often works with computers. No luck.

I have restored the original factory settings.

The battery is fully charged.

I have tried different settings: M, SV, TV, AV TAV, and P

I am running the most recent update for the K10.

Makes no difference whether I am using a DA lens or an old M series lens.

Makes no difference whether the camera is set to auto or manual.

Other than this glitch everything else seems normal. Any ideas or suggestions?

Thanks

Tom G


Last edited by 8540tomg; 07-30-2014 at 03:18 PM. Reason: typo
07-30-2014, 03:24 PM   #2
Senior Member
Alcazar's Avatar

Join Date: Jan 2008
Location: Stuttgart, Germany
Posts: 212
it's the number of shots that you can take before your card is full :-) quite useful feature actually
07-30-2014, 03:32 PM   #3
Veteran Member
Joel B's Avatar

Join Date: Aug 2013
Location: Des Moines, Iowa
Photos: Albums
Posts: 2,336
Yep that's a shot counter. Now you said it used to show your iso there? I wonder if the latest firmware upgrade changed the use of that section of the lcd. My k100D has always had the counter there even with firmware upgrades. Send Adam a shout out, maybe he'll know.
07-30-2014, 03:32 PM   #4
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
I don't recall ever seeing the ISO here, unless you are adjusting it in TAv mode perhaps

07-30-2014, 03:55 PM   #5
Pentaxian
8540tomg's Avatar

Join Date: Feb 2008
Location: Waterloo, Ontario
Photos: Gallery
Posts: 4,454
Original Poster
Really - a shot counter. I never realized that.

I looked in the manual under shot counter and counter and found nothing.

I haven't used the K10 for quite a while as I use the K5 almost all the time.

I guess I got used to seeing the ISO setting in the K5 panel in that area.

Good to know nothing is wrong.

In my defense the guy at Henry's Camera in Waterloo couldn't figure it out either. Still feel pretty dumb though.

I should have come straight to the Forum. All the experts are found here.

Thanks for clearing that one up guys.

Tom G
07-30-2014, 05:12 PM   #6
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 4,260
When you press the "Ok" button on the 4-way controller it changes to ISO and you can set the ISO with the front e-Dial.
07-30-2014, 05:27 PM   #7
Pentaxian
8540tomg's Avatar

Join Date: Feb 2008
Location: Waterloo, Ontario
Photos: Gallery
Posts: 4,454
Original Poster
QuoteOriginally posted by Not a Number Quote
When you press the "Ok" button on the 4-way controller it changes to ISO and you can set the ISO with the front e-Dial.
Thanks mon ami.

I'll check that out as I get reacquainted with my K10.

Still a pretty good camera.

Tom G
07-30-2014, 06:18 PM   #8
Senior Member
Alcazar's Avatar

Join Date: Jan 2008
Location: Stuttgart, Germany
Posts: 212
QuoteOriginally posted by Not a Number Quote
When you press the "Ok" button on the 4-way controller it changes to ISO and you can set the ISO with the front e-Dial.
Ha! I didn't know that. Thanks to you i find out new things about my K10D still after 7 years :-)

07-30-2014, 07:22 PM   #9
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,445
QuoteOriginally posted by Alcazar Quote
Ha! I didn't know that. Thanks to you i find out new things about my K10D still after 7 years :-)
I found it out only a few weeks before I sold my K10D.


Steve
07-30-2014, 08:56 PM   #10
Pentaxian




Join Date: Nov 2013
Location: North Carolina
Posts: 1,116
QuoteOriginally posted by 8540tomg Quote
Really - a shot counter. I never realized that.

I looked in the manual under shot counter and counter and found nothing.

I haven't used the K10 for quite a while as I use the K5 almost all the time.

I guess I got used to seeing the ISO setting in the K5 panel in that area.

Good to know nothing is wrong.

In my defense the guy at Henry's Camera in Waterloo couldn't figure it out either. Still feel pretty dumb though.

I should have come straight to the Forum. All the experts are found here.

Thanks for clearing that one up guys.

Tom G
The counter is a conservative " guesstimate". My K5/K5IIs will show "464" with an empty 16Gb Card but I'll typically get about 600+ DNGS. 64Gb Cards display "1844" and I've done 2400+. It depends on how high frequency the detail is in the image.

The counter is something I always keep an eye on when shooting two performances, matinee and evening. Changing cards in the dark is not recommended. One slip and a days work is under a seat 3 rows away. With my luck, its stuck to a shoe that's walking out of the theater ;-)
07-30-2014, 09:48 PM   #11
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 4,260
The ISO shows in the viewfinder too. A nice, quick way to see what it is set to is just to press the "OK" button.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, images, iso, k10, lens, pentax help, settings
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto ISO question fiveo Pentax K-5 14 02-20-2014 03:55 PM
Camera question/ISO question Photography91 Troubleshooting and Beginner Help 2 01-07-2014 07:56 AM
ISO Question Sol Invictus Photographic Industry and Professionals 5 10-06-2012 04:03 PM
K5: -/+ and ISO button question. Riv Pentax K-5 6 09-10-2012 01:07 PM
Night photography with K10D - High ISO short exposure VS Low ISO long exposure pw-pix Pentax DSLR Discussion 10 02-03-2008 01:37 AM



All times are GMT -7. The time now is 02:47 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top