Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-02-2014, 10:05 AM   #1
New Member




Join Date: Aug 2014
Posts: 4
Can't set shutter speed

Hi-
I have a K100d. Lately I've had trouble setting the shutter speed; I turn the dial, sometimes the numbers change, sometimes they don't. I need to turn the camera off and on, set it to manual, halfway depress the shutter and press the AE-L button to set the speed. Having done this I can then set the speed with the dial. But only once, and only in one direction For example: speed set to 50 with AE-L, I can go to a faster or slower speed from that start, but once I change direction the speed usually jumps to 4000. At which point turning the wheel makes no sense: the screen will read 4000 no matter which direction I spin the wheel or it will jump between 4000 and 2500. The only way to change the shutter speed at this point is to stop and start the camera? Anyone else encountered this?
Thanks,
JL

08-02-2014, 11:58 AM   #2
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,881
It could be that the e-dial needs to be cleaned.

Maybe this thread on a similar problem with the K-r could help you solve the issue.
08-02-2014, 02:10 PM   #3
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 6,558
QuoteOriginally posted by JLM Quote
Hi-
I have a K100d. Lately I've had trouble setting the shutter speed; I turn the dial, sometimes the numbers change, sometimes they don't. I need to turn the camera off and on, set it to manual, halfway depress the shutter and press the AE-L button to set the speed. Having done this I can then set the speed with the dial. But only once, and only in one direction For example: speed set to 50 with AE-L, I can go to a faster or slower speed from that start, but once I change direction the speed usually jumps to 4000. At which point turning the wheel makes no sense: the screen will read 4000 no matter which direction I spin the wheel or it will jump between 4000 and 2500. The only way to change the shutter speed at this point is to stop and start the camera? Anyone else encountered this?
Thanks,
JL
Does this occur in all mode dial positions?
08-03-2014, 08:07 AM   #4
JLM
New Member




Join Date: Aug 2014
Posts: 4
Original Poster
dial resopnse

Yes, it's weird in all positions, does not respond or responds wildly, jumping all over.

---------- Post added 08-03-14 at 11:09 AM ----------

QuoteOriginally posted by Ole Quote
It could be that the e-dial needs to be cleaned.

Maybe this thread on a similar problem with the K-r could help you solve the issue.
That link was down but I'll try cleaning it.
Thanks.

08-16-2014, 04:01 PM   #5
Site Supporter
OldGeaser's Avatar

Join Date: Jan 2014
Location: Thousand Oaks, CA
Posts: 221
I have a similar problem with my Kx. Sent it to Eric for repair. He replied that he will clean the contacts but that it may need to be sent in for service. I presume he means Pentax Service. I will post again when I get my camera back. Very frustrating!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
ae-l, camera, change, direction, k100d, pentax help, shutter, shutter speed, wheel
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't select 1/180 shutter speed carlosodze Troubleshooting and Beginner Help 2 04-05-2014 06:48 PM
Can't set film speed on SP500 sonyhandycam520 Pentax Film SLR Discussion 4 01-07-2014 03:00 PM
How to set shutter speed with ISO.. JWS Troubleshooting and Beginner Help 6 07-06-2012 08:20 PM
Unable to set shutter speed? Eagle94VT Pentax K-5 9 02-25-2012 10:08 PM
Trying to set Shutter Speed daisydawn Pentax DSLR Discussion 2 11-08-2011 02:08 PM



All times are GMT -7. The time now is 10:20 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top