Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-02-2014, 09:43 PM   #1
Senior Member
Liney's Avatar

Join Date: Apr 2013
Posts: 240
K100 D Super Autofocus

Oh great and wise forum

Spent a bit of time last week playing with my extension tubes doing a bit of macro work, but this week I tried taking some portrait shots. Trouble is, auto focus just did not want to play at all.

By "did not want to play" I mean that the lens does not try to focus in auto mode (no drive at all) and if I manually try and focus the lens I don't get any indication that the camera thinks the lens is focused. Auto focus is definately selected (and deselected, and selected gain) and I've tried two different auto focus lenses with the same results.

It sounds as if there are two seperate faults, one to drive the lens and one to get the focus indicationin the viewfinder, no red spot in the viewfinder and no 'beep'.

So anyone got any ideas?

Cheers

08-02-2014, 11:34 PM   #2
Site Supporter




Join Date: Apr 2011
Photos: Albums
Posts: 2,893
Have you checked the menus to make sure that you have not accidentally switched off auto focus.


OR there is a MF/AF switch on the left side of the mount. Could have got knocked accidentally.
08-02-2014, 11:48 PM   #3
Senior Member
Liney's Avatar

Join Date: Apr 2013
Posts: 240
Original Poster
tim60

Thanks for the response, good of you to chip in.

It's OK, panic over. I checked through the menu settings and right down in the weeds of a "Custom" menu selection there is a little menu item called "OK btn when shooting". Seems if you select this to "Enable AF" it doesn't do what I thought it did.

I had a real panic there that I'd managed to bust two autofocus lenses and the camera body, Now I need to work out why I changed it in the first place...!

Cheers again
08-03-2014, 01:03 AM   #4
Site Supporter




Join Date: Apr 2011
Photos: Albums
Posts: 2,893
I have a K100DS and did encounter such things. I used MF lenses a lot with it, and sometimes forgot to return settings when I put the kit lens on and gave it to someone else, like my wife to use. One time she passed it to someone else, who I think moved the MF/AF switch - result was a wasted session of pictures.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, bit, drive, focus, lens, pentax help, viewfinder, week
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Telephoto Lens For K100 Super D Richm Visitors' Center 2 08-13-2013 02:18 PM
Help please with K100 D Super alisonkim Troubleshooting and Beginner Help 11 02-13-2012 07:00 PM
k100 d super won't go into auto flash mode tdmsu Troubleshooting and Beginner Help 2 11-04-2011 05:17 AM
K100 D Super T Edwards Pentax DSLR Discussion 3 03-06-2010 10:42 AM
k200D vs. K100 Super D LSC Pentax DSLR Discussion 2 07-27-2008 09:23 AM



All times are GMT -7. The time now is 06:23 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top