Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-08-2014, 09:00 PM   #1
Site Supporter
kev.pride's Avatar

Join Date: Feb 2008
Location: Modbury North, South Australia
Photos: Gallery | Albums
Posts: 345
K3 Firmware update 1.10

After inserting a formatted SD card (with the firmware installed into the top area outside of folders) into slot 1 and then holding the Menu button down as I turn on the K3 it simply opens up to the normal start up screen.

Followed all the steps as per the Ricoh firmware download page.

Any ideas on why this is occurring.

Kevin

08-08-2014, 09:11 PM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,286
Slot #1 is toward the front of the camera. I get them confused, so first thing I would check.

Second is the file needs to be the .bin file and be in the root of the card. Verify that you have the .bin, not the .exe or .zip
08-08-2014, 09:41 PM   #3
Senior Member
Pavel_Zhelev's Avatar

Join Date: Aug 2014
Posts: 190
How is that possible to have folders on formated card? Please check if the card was properly formated as well as the slot number.
Hope it works.

QuoteOriginally posted by kev.pride Quote
After inserting a formatted SD card (with the firmware installed into the top area outside of folders) into slot 1 and then holding the Menu button down as I turn on the K3 it simply opens up to the normal start up screen.

Followed all the steps as per the Ricoh firmware download page.

Any ideas on why this is occurring.

Kevin
08-08-2014, 10:14 PM - 1 Like   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,954
QuoteOriginally posted by kev.pride Quote
After inserting a formatted SD card (with the firmware installed into the top area outside of folders) into slot 1 and then holding the Menu button down as I turn on the K3 it simply opens up to the normal start up screen.

Followed all the steps as per the Ricoh firmware download page.

Any ideas on why this is occurring.

Kevin
Make sure you extract the download. A .BIN file should be in the root of the SD. Firmware update guide:

Pentax Firmware Update Guide - Tutorial Videos


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-08-2014, 10:43 PM   #5
Site Supporter
kev.pride's Avatar

Join Date: Feb 2008
Location: Modbury North, South Australia
Photos: Gallery | Albums
Posts: 345
Original Poster
Thanks for responses, what appears to be happening is the downloaded exe file is not self opening as it is supposed to do.

.EXE file also says self extracting for win32 files - would this be a problem with a 64bit win on win7.

How do I get it so that the file has the 2 sub files (.bin & .txt) files.

Kevin
08-08-2014, 10:57 PM - 1 Like   #6
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,182
QuoteOriginally posted by kev.pride Quote
.EXE file also says self extracting for win32 files - would this be a problem with a 64bit win on win7.

How do I get it so that the file has the 2 sub files (.bin & .txt) files.
Download to your computer and double click to execute the .EXE file. This should result in extraction of a .bin and a .txt file to the same directory. Copy these into the root directory of the SD card.


Steve
08-08-2014, 11:19 PM   #7
Site Supporter
kev.pride's Avatar

Join Date: Feb 2008
Location: Modbury North, South Australia
Photos: Gallery | Albums
Posts: 345
Original Poster
Thanks for help - this Forum is great.

Not as if this is the 1st time I have downloaded a Firmware update for the various Pentax DSLR's I have owned over the years.

Stupid Win 7 & my Antivirus kept giving warning messages - and the extracted file was in another folder all along. Once I found it and copied to SD card etc. etc it has worked fine.

Thanks again to all who helped.

Kevin
05-30-2015, 02:19 PM   #8
New Member




Join Date: May 2015
Posts: 18
Same thing has happened to me ..gave up after trying for an hour..will open file first and see if that eorks

05-30-2015, 11:00 PM   #9
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
QuoteOriginally posted by kjbatch Quote
Same thing has happened to me ..gave up after trying for an hour..will open file first and see if that eorks
Instead of reviving an old thread, try the suggestions in your other thread first.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
firmware, k3, k3 firmware, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 Firmware Update 1.10 Released sab Pentax News and Rumors 49 09-11-2014 07:31 PM
Firmware Update K3 robrob41 Troubleshooting and Beginner Help 9 07-31-2014 11:31 AM
Issue with exposure meter in viewfinder after firmware 1.10 update SamCam Pentax K-3 3 07-25-2014 02:40 PM
K3 Crazy Mirror Sickness (Mirror Flapping Lockup) on firmware 1.10 SteveUK Pentax K-3 13 07-22-2014 08:08 PM
could ISO 80 be possible on the k3 with a future firmware update? Rice Pentax K-3 2 05-19-2014 09:21 PM



All times are GMT -7. The time now is 03:49 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top