Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-09-2014, 07:10 PM   #1
Site Supporter
Pepe Guitarra's Avatar

Join Date: Nov 2010
Location: California
Photos: Gallery | Albums
Posts: 2,048
My K-3 Electronic Level is ON all the time.

I was shooting today and for no reason, the electronic level showed up on my back screen. I thought I had accidentally triggered and went to see the settings. NO, the setting had the electronic level OFF in both cases, viewfinder and live mode. I thought it was a case of battery, I pulled it out and changed it, NO. Nothing happened. I thought I could fix it with an update of the firmware. I have the Version 1.03 installed, and I realized there is a new 1.10. I downloaded the BIN file (no tex file, only one) because I have a Mac. Then I follow the instructions load the 32 MG card with the file in the root directory (I double click it and it creates another file, but that is it!), put a fully loaded battery, press and hold the MENU bottom and start the camera. The camera does not read anything about firmware and just starts normal. I have done and redone the process to no avail. I read a posting from someone yesterday and check, and I am doing the right thing. Do you think it is time to send it for technical repair?

Thanks, Pepe

08-09-2014, 07:40 PM   #2
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,250
The download is a .zip file. Have you unzipped it before copying it to the root of the camera-formatted SD card?
08-09-2014, 07:57 PM   #3
Pentaxian
fgaudet's Avatar

Join Date: Oct 2013
Location: Ontario
Posts: 726
QuoteOriginally posted by Pepe Guitarra Quote
I double click it and it creates another file, but that is it!
If you double click the fwdc220b.bin, it'll create another file in fwdc220b.bin.CPGZ which will not work as a firmware update file. On your Mac if your finder isn't setup to show extensions, you won't see the difference

---------- Post added 08-09-14 at 23:02 ----------

And regarding your level, if you press INFO twice you should be able to select a different info screen for the camera. Or turn it off completely
08-09-2014, 08:20 PM   #4
Site Supporter
Pepe Guitarra's Avatar

Join Date: Nov 2010
Location: California
Photos: Gallery | Albums
Posts: 2,048
Original Poster
fwdc220b.bin & fwdc220b.bin.CPGZ are the two files I have on the card. I am thinking that the problem may be other, the camera is always showing the electronic level.

---------- Post added 08-09-14 at 08:38 PM ----------

Thanks, I solved the display problem. I also solved the firmware. However, while the NOW LOADING sign was showing, I was distracted for a second and did not notice exactly if the COMPLETE signs came out. It is about 10 minutes since the display is black. Should I turn the camera down? How long does it take the whole firmware update?

Never mind. I turned it off after 10 minutes, and restarted and all is right! OK. Thanks, Pepe


Last edited by Pepe Guitarra; 08-10-2014 at 09:52 PM.
08-10-2014, 10:14 AM   #5
Site Supporter




Join Date: May 2014
Location: Minnesota
Posts: 1,182
On my K-5 II the Complete sign displays until you turn off the camera. Another thing I'm not sure what camera you are using, but a firmware download should not last 10 minutes.
08-10-2014, 09:53 PM   #6
Site Supporter
Pepe Guitarra's Avatar

Join Date: Nov 2010
Location: California
Photos: Gallery | Albums
Posts: 2,048
Original Poster
I am using the K-3, and the whole thing lasted about 2 minutes. I waited about ten to turn the camera off. It worked. All is fine.
08-12-2014, 01:54 AM   #7
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 30,641
QuoteOriginally posted by Pepe Guitarra Quote
I waited about ten to turn the camera off
Bet that was the longest 10 minutes ever.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, click, display, electronic level, file, firmware, info, k3, level, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electronic Level K-5 ii A_Dave Pentax K-5 4 03-29-2014 03:51 AM
How's the Electronic Level in the K-5II ChrisA Pentax K-5 4 10-14-2013 06:19 PM
does anyone use the electronic level ? glinda Photographic Technique 18 12-07-2012 09:36 AM
Is the electronic level accurate for you? m8o Pentax K-5 25 11-30-2010 10:19 AM
k-5 issue with the electronic level :( bsimon Pentax K-5 20 10-29-2010 08:13 PM



All times are GMT -7. The time now is 12:12 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top