Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-24-2014, 10:06 AM   #1
New Member




Join Date: Oct 2012
Photos: Gallery | Albums
Posts: 20
Problems with Pentax K-x

I have a Pentax K-x that I bought new in 2009. Recently I have been using it in Manual mode, but today I went to Auto pic mode, auto focus, and the pictures were over exposed. I tried landscape and portrait mode and still over exposed. I went into the settings and reset them, but still no difference. I've tried several different lens' with no luck. Plus it seems to be taking a lot longer to auto focus.

The camera uses AA batteries I use only the Lithium ones, they are new and the indicator shows full power

I believe the shutter count is around 17K

08-24-2014, 10:35 AM   #2
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,772
- Exposure compensation set to something?
- Does it work correctly in Av mode or Tv mode?
- What metering mode do you have set?
08-24-2014, 11:33 AM   #3
New Member




Join Date: Oct 2012
Photos: Gallery | Albums
Posts: 20
Original Poster
I have gone in and changed everything back to green, metering mode set to auto, no Tv and Av mode I am getting the same thing,
08-24-2014, 11:34 AM   #4
Site Supporter
Site Supporter
forensicscientist's Avatar

Join Date: Jun 2008
Location: DFW Texas and Maine - I commute :)
Posts: 889
What is your ISO set to??

08-24-2014, 11:37 AM   #5
New Member




Join Date: Oct 2012
Photos: Gallery | Albums
Posts: 20
Original Poster
Just taken today Sunday 24 Aug 14 at 2:35

Not sure if this will help or not?

---------- Post added 08-24-14 at 04:43 PM ----------

QuoteOriginally posted by forensicscientist Quote
What is your ISO set to??

ISO is set for AUTO 400 - 800
Attached Images
View Picture EXIF
PENTAX K-x  Photo 
08-24-2014, 11:44 AM   #6
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,772
First thought would be that the lens aperture blades are sticking. But if you tried this with multiple lenses that kinda knocks that idea. Unless it is the aperture lever on the camera.

Try a series of identical shots in manual, changing only the aperture setting. The exposure should change with each shot. If it does not, then the lens is not stepping down when the shot is being taken.
08-24-2014, 12:04 PM   #7
New Member




Join Date: Oct 2012
Photos: Gallery | Albums
Posts: 20
Original Poster
Okay, I think I fixed it, even though the batteries said they were fully charged, I changed them anyway and now it is running back to normal the shutter and auto focus, sound and work better.

Still might be time to move up to a newer camera
08-24-2014, 06:09 PM   #8
Pentaxian
Kozlok's Avatar

Join Date: Jun 2012
Location: Albuquerque
Photos: Gallery
Posts: 1,793
QuoteOriginally posted by GrizzlyThumper Quote
Still might be time to move up to a newer camera
ALWAYS time to move up to a newer camera! Dual control wheels and WR are great!

08-24-2014, 07:34 PM   #9
Pentaxian
Edgar_in_Indy's Avatar

Join Date: May 2010
Location: Indiana, USA
Photos: Gallery
Posts: 2,636
The K-x is a hell of a camera. If you're on a tight budget, I wouldn't replace it unless you need to. That being said, my K-30 was a nice bump up in sensor performance from my K-x.
08-24-2014, 07:40 PM   #10
Senior Member




Join Date: May 2010
Location: Catalao GO Brasil
Photos: Gallery
Posts: 151
I had the opposite problem with my white K-x a few years ago. I had nothing but underexposed shots, even with flash. I found out the camera was taking everything in the smallest aperture (in my case f22), regardless of the aperture set on camera. I took the body to a Pentax tech service and the guy reported an electronic problem with the aperture control circuitry. Since they did not have that specifc spare part, they could not fix it for me. I was only able to use the camera in M mode with old lenses that had aperture ring. I ended up using it only in M mode for 1 1/2 year until I could buy a new body, and now my K-x is well packed in its original box in my closet. It's my backup, just in case I need a second body.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, exposed, focus, iso, k-x, mode, pentax, pentax help, pentax kx
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with setting the f-values (Pentax X-5) Didi Cannucci Troubleshooting and Beginner Help 10 09-01-2013 03:40 PM
Problems with focusing K-x Mangoman45 Troubleshooting and Beginner Help 6 08-27-2013 07:01 AM
K-X stop down metering problems with fast lenses i_trax Pentax DSLR Discussion 3 07-27-2011 06:00 AM
Problems with K-X exposure Drew Hillier Troubleshooting and Beginner Help 5 05-24-2011 05:14 PM
Apple fixes RAW problems with K-7 & K-x boriscleto Digital Processing, Software, and Printing 6 04-26-2010 11:50 AM



All times are GMT -7. The time now is 04:28 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top