Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-27-2014, 02:43 PM   #1
Site Supporter




Join Date: Apr 2008
Location: New jersey
Photos: Gallery
Posts: 152
Silky pixs and USB connection problems

I tried to download the silkypixs software that came with my new k50 on my Mac. It will not download. Any suggestions? Also, when I connect my camera to to my Mac via the USB port, it is not recognized Anyone else have this issue and how can it be solved. I might just use my i photo as I heard silkypixs isn't that great anyway.

08-27-2014, 03:00 PM   #2
Pentaxian
Miguel's Avatar

Join Date: Sep 2007
Location: Near Seattle
Photos: Gallery
Posts: 2,694
Try a card reader. It is a better way to upload image data to your Mac anyway.

M
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, download, mac, pentax help, photography, pixs and usb, silkypixs, usb, usb connection
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lens connection problems Schuette Troubleshooting and Beginner Help 17 07-04-2011 09:03 AM
USB connection sub5runner Troubleshooting and Beginner Help 6 06-15-2010 07:13 PM
Disconnected camera w/out ejecting and now NO USB connection imno007 Troubleshooting and Beginner Help 11 05-29-2010 09:26 AM
Download: Remove SD card or plug in USB connection? laissezfaire Pentax DSLR Discussion 40 12-16-2008 10:41 AM
USB connection problem..K100D arbutusq Pentax DSLR Discussion 6 12-28-2006 09:19 PM



All times are GMT -7. The time now is 03:36 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top