Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-08-2014, 10:09 AM   #1
New Member




Join Date: Sep 2014
Posts: 3
'Deleting' appears in screen insted of image

When photo taken with my istD 'Delete' appears in the bottom left of screen. No image at all. I am using the same SD card as usual (1 gig) which indicates 63 jpegs space available. Have tried new batteries. Contacts on the SD card appear clean. Have deleted a number of existing images to make more room but to no effect. All other functions appear good.
Any suggestions guys?

09-08-2014, 11:33 AM   #2
Senior Member
kiberkli's Avatar

Join Date: Aug 2013
Location: Central Valley, California
Posts: 112
Can you see other images when you review them using the play button (button w/blue right pointing triangle in a blue square)? Does this happen with only one image or all of them on the SD card?
09-08-2014, 01:19 PM   #3
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 11,005
I would suggest you copy the images to your computer. Then you make sure the card is not in "lock" mode. Make sure you are running the latest firmware update for your camera. Then put the SD card into the camera and format it. Formatting will delete all data on the card and should fix any kind of hiccups.
If problems persist, there is either a problem with the card or the camera. Cards these days are fairly cheap, and if you buy one and it turns out to be a camera fault, you can still use the SD card with other cameras. I suggest you get a good SD card, like Sandisk or Lexar. And make sure its a format your camera can read (I don't know if the istD can work with SD XC cards)
09-11-2014, 11:57 AM   #4
Site Supporter
Site Supporter
tomwil's Avatar

Join Date: May 2009
Location: Maryland USA
Posts: 778
QuoteOriginally posted by Na Horuk Quote
Cards these days are fairly cheap, and if you buy one and it turns out to be a camera fault, you can still use the SD card with other cameras. I suggest you get a good SD card, like Sandisk or Lexar. And make sure its a format your camera can read (I don't know if the istD can work with SD XC cards)
I believe the *istD takes the older Compact Flash card. Rather useless in modern equipment.

09-12-2014, 01:02 PM   #5
New Member




Join Date: Sep 2014
Posts: 3
Original Poster
'Deleting' appears in screen instead of image

Thanks for your replies guys.
The images on the SD card are OK. The problem only arises when I take a new image.
I have now as suggested deleted all the images on the card (afer saving them on my pc). The camera now indicates space for 341 images (1 gig card). So it is recognising the card but still when I take an imge all I get on the view screen is 'Deleting'
Have also purchased a new card a SDHC class 4. Camera indicates 'Card Error'. Should this be compatible?
As to checking the firmware - I don't have the instructions / disc any more so don't know how to go about this. I will try searching for Pentax Firmware and see what come up.
09-12-2014, 01:46 PM   #6
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,797
Dont just delete, do a card format in the camera.

Firmware is available here http://www.ricoh-imaging.co.jp/english/support/download_digital.html

Last edited by crewl1; 09-12-2014 at 01:51 PM.
09-13-2014, 11:12 PM   #7
Veteran Member
rburgoss's Avatar

Join Date: May 2008
Location: San Jose, Costa Rica
Photos: Gallery | Albums
Posts: 972
Something is bugging me about all this. My *istD uses CF (compact flash) cards. Not SD cards. Are you using some kind of card adaptor to be able to use SD?

If so, try using a regular CF card. Such adaptor's inner contact may be dirty or bad.

The problem you are describing comes usually from bad contacts, that may be at memory card, camera's card contacts or even dirty switches inside camera body. First rule out memory card problem by testing with different CF cards without any adaptor. If still happens, then check body by restoring firmware. Last, have body checked at a reputable shop.

Lets us know your findings.
09-14-2014, 09:14 AM   #8
Site Supporter
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,814
QuoteOriginally posted by rburgoss Quote
My *istD uses CF (compact flash) cards. Not SD cards.
Good catch. An adapted CF may well be the source of the problem.


Steve

09-20-2014, 08:28 AM   #9
New Member




Join Date: Sep 2014
Posts: 3
Original Poster
Hi Rburgos,
Good thought but am not using an adapter. SD cards are the standard it seems for the early istDL (as sold in UK with version 1.0 firmware).
Have tried reformatting the card in the camera but while it recognises the card it still deletes any new image.
It could be there is some latent damage from when I dropped camera last year although it was working OK since.
Have just ordered a used DL2 body from e-bay as a back-up. So will try the card from this to see if it works. Failing that as you suggest will
re-load/update the firmware.
Thanks everyone for your suggestions.
09-20-2014, 10:48 AM   #10
Site Supporter
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,814
QuoteOriginally posted by Toxophilist Quote
Have also purchased a new card a SDHC class 4. Camera indicates 'Card Error'. Should this be compatible?
If you have firmware 1.03, that card should be usable. To check your firmware version, turn the camera on while holding down the "menu" button.

Based on your description, there is a chance that the file system on the card may be degraded in a way that the in-camera format cannot remedy. There is a free tool available from the SD Association (industry consortium) Web site that allows a deep format with a full-rewrite of the file system.

https://www.sdcard.org/downloads/formatter_4/

Follow up with an in-camera format. Good luck!


Steve

---------- Post added 09-20-14 at 10:54 AM ----------

BTW, you can download a copy of the *ist DL user manual from Ricoh Imaging:

Downloads & Literature - RICOH Imaging


Steve
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
'delete' instead of image, camera, card, file, firmware, format, image, in-camera, pentax help, ricoh, screen, sd, steve
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Which part of an image is in focus? MSL Digital Processing, Software, and Printing 7 05-06-2013 08:10 PM
Sale of image, requires "20x30 image size digital image" ? NeverSatisfied Digital Processing, Software, and Printing 25 03-29-2013 05:38 AM
Circle appears in all shots. K-30 grinnersinc Troubleshooting and Beginner Help 13 09-01-2012 10:09 PM
Time before image review appears on LCD screen FreezeFrame Pentax K-r 7 04-25-2012 07:54 AM
Pentax k-x: Use laptop insted of LCD screen to manually adjust sharpness Esp1Holm Pentax DSLR Discussion 7 05-05-2010 10:03 AM



All times are GMT -7. The time now is 01:00 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top