Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-13-2014, 08:13 PM   #1
New Member




Join Date: Sep 2014
Posts: 5
K100D Battery Problem

I was shooting most of the day and late in the day i was given the warning that the "battery was deleted". I tried my spares. same message. got home opened new package of batteries. same message.
the last set was new. the others tested as good. any suggestions for repair. I have had this used camera for about 3 years without a problem.

09-13-2014, 09:37 PM   #2
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,829
Check the contacts in the battery compartment? A small amount of corrosion can cause the camera to not see the batteries. Unusual, but first thing to check. Use a pencil eraser to brighten the contacts.
09-14-2014, 07:12 AM   #3
Site Supporter
Site Supporter
jlstrawman's Avatar

Join Date: Feb 2010
Location: Des Moines, Iowa
Photos: Gallery
Posts: 545
QuoteOriginally posted by cal Quote
got home opened new package of batteries. same message. the last set was new. the others tested as good. any suggestions for repair. I have had this used camera for about 3 years without a problem.
If you have been using alkaline batteries, you will have better luck by discontinuing their use. Use quality rechargeables, such as Sanyo Eneloop
09-17-2014, 03:08 PM   #4
cal
New Member




Join Date: Sep 2014
Posts: 5
Original Poster
The Energizer Lithium solved my problem. Thanks for all the suggestions. i still don't see why It suddenly decided to not accept the various other types of batteries I have been using without a problem for the past several years. I did clean the contacts with a ink type eraser. that didn't help. Oh well, its working now and I have my fingers crossed.
Thank you to all for the suggestions.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, day, dead battery indicates, dslr, k100d =, message, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K100D battery reading problem pamss Pentax DSLR Discussion 22 11-14-2016 02:47 AM
battery problem Sue Saunders Welcomes and Introductions 3 10-26-2012 11:46 AM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
For Sale - Sold: Battery Grip for K100D/K110D/K100D Super Camera, K10D/K20D D-LI50 Battery frank Sold Items 12 05-30-2009 06:10 PM
K100D - "Low-Battery" Problem Teja Pentax DSLR Discussion 53 01-02-2008 10:24 AM



All times are GMT -7. The time now is 01:07 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top