Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-14-2014, 03:23 PM   #1
Junior Member
AbadPhotography's Avatar

Join Date: Jul 2014
Location: Tulsa Oklahoma
Posts: 29
K-3 Glitch. very perplexing.

I've had my K-3 since February this year and have been having an inconsistent but disturbing problem.

The problem seems to happen when I use manual lenses(and by manual I mean no auto or 'A' feature at all). I always have it in the manual setting for my old lenses. Sometime after taking a picture my LCD and information in my veiwfinder go off but the top LCD display remains on. I can't do anything, the camera becomes a vegetable. Even when I turn it off the camera still displays a few numbers on the top LCD, kinda like when it's plugged into the computer. When I flip the switch back on everything seems normal and I can release the shutter, but it won't write to the memory card.

In the end I have to pull the battery to get things back top normal. And if I'm lucky haven't lost any photos.

What's going on here? I would appreciate any help. Thank you
-Chris

09-14-2014, 03:32 PM   #2
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,105
Have you called Ricoh? This sounds like a warranty issue. Are you sure it only happens when non-A contact lenses are mounted? The reason I ask is that there is a known problem where the camera simply becomes unresponsive until the battery is removed as a form of reset.


Steve
09-14-2014, 03:50 PM   #3
Junior Member
AbadPhotography's Avatar

Join Date: Jul 2014
Location: Tulsa Oklahoma
Posts: 29
Original Poster
QuoteOriginally posted by stevebrot Quote
Have you called Ricoh? This sounds like a warranty issue. Are you sure it only happens when non-A contact lenses are mounted? The reason I ask is that there is a known problem where the camera simply becomes unresponsive until the battery is removed as a form of reset.


Steve
Yes and at the time they had no response(this was in march). I noticed it first switching between live view and the viewfinder so I just avoided live view. But the last time was during using the view finder. I have yet to update to the latest firmware. Maybe that will help?
09-15-2014, 02:13 AM   #4
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 6,187
Try the latest firmware. The other thing could be that there's a short with the lack of contacts on the old lenses, but it should not happen.

09-15-2014, 02:30 AM   #5
Junior Member
Unsane's Avatar

Join Date: Sep 2014
Location: Somewhere in the Welsh Marches
Photos: Albums
Posts: 48
I've been using M series lenses loads with my K-3 and thus far have had no problems.
I'd try the latest firmware just in case, seems like an issue with your camera though (I used a 28mm M with no issues on the default firmware before updating)
09-16-2014, 01:13 AM   #6
Senior Member
screwdriver222's Avatar

Join Date: Oct 2011
Location: Plymouth
Photos: Gallery | Albums
Posts: 131
My K3 and m50 f1.7 combination works fine. I think you must have a camera problem.

Regards

Jeff
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-3, lcd, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-r glitch? Shutter fires every time I press any button. Help? MrA Pentax K-r 22 12-09-2016 07:56 AM
K-30 Glitch RTFM Troubleshooting and Beginner Help 10 02-12-2014 01:04 PM
Pentax K-7 Meter Glitch? K David Pentax DSLR Discussion 6 01-22-2014 02:39 PM
My First K-3 Glitch K David Pentax K-3 6 11-18-2013 02:40 PM
Very very cheap K-01 jena Pentax K-01 7 03-28-2013 04:44 PM



All times are GMT -7. The time now is 03:51 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top