Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-14-2014, 03:54 PM   #1
New Member




Join Date: Feb 2010
Location: Litiz
Posts: 7
K10D will not recognize any lens

I was taking some pictures at my nephew's christening, switching between my 18-55 and a 135mm m42 lens. When suddenly after switching from the 135mm to the zoom, mall of my shots were grossly overexposed. Now, everytime I turn the camera on with modern lens, I am prompted to tell the camera what focal length the lens is. If SR is turned off, I simply cannot change the aperture (it does this after I give the camera the focal length).

I have tried clening the contacts on the mounts of the camera and lenses, but that didn't work. It started out as an intermittent problem, but is now constant.

I don't know if it makes a difference, but the adapter for the m42 mount is one of the black ones, not one of the silver ones that I am now seeing for sale.

Also, a couple years ago, I was hhiking through a 5 hour down pour with a DA*16-50 on the camera the whole time. The camera didn't miss a beat while I was hiking. But, when I got back to the car and tried to review my shots, it wouldn't do anything. I then left the camera (apart) in front of a dehumidifier for a week, and all was well. Except for the auto focus in the DA*. I don't think that this has anything to do with my current problem, but stranger things have happened.


Last edited by davedotwojo; 09-14-2014 at 04:01 PM.
09-14-2014, 06:10 PM   #2
Senior Member




Join Date: May 2014
Posts: 100
I have the same issue with my k3 and older lenses now and again.. Sometimes with the focus as well..but generally it's auto aperture not closing
09-14-2014, 07:29 PM   #3
Senior Member
j0n4hpk's Avatar

Join Date: Apr 2009
Location: California
Photos: Gallery | Albums
Posts: 183
Hi davedotwojo. Try powering off the K10D camera, removing the battery for 1 minute, reinstalling it and powering it up and trying test shots with a Pentax-branded DA, FA or F lens only. If it fails, review what configurations settings you changed on the camera, get to the Set-up menu setting to Reset all values in the camera and press OK button. Then try shooting with any of the lenses mentioned before. If it definitely doesn't work, try Reset from the Custom Functions menu and test afterward. I hope it works.
09-14-2014, 08:06 PM   #4
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 3,894
How are you cleaning the contacts? I would avoid anything abrasive like a pink eraser. White erasers should be ok but you have to worry about getting crumbs inside the camera and lens. I would take a bit of cotton T-shirt or micro-fiber material and sparingly moisten it with alcohol and gently wiping the contacts and that area of the mount. You want to avoid working too much alcohol into the contacts. Wipe it dry with a clean cloth. Check to make none of the pins are stuck down. The "A" pin on the camera mount will be slightly depressed relative to the others on the camera mount. On the lens mount it should protrude slightly more than the other pins. The height or depth of all the pins except the "A" pin should be the same.

Is the M42 adapter flanged or not?

09-15-2014, 06:52 AM   #5
New Member




Join Date: Jan 2009
Location: Nova Scotia
Photos: Gallery
Posts: 17
Have you checked that the apeture ring is set to A and hasn't been knocked to a fixed setting?
09-15-2014, 12:50 PM   #6
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 3,894
I don't think any of the 18-55mm zooms have aperture rings. If it has a plastic mount perhaps it has just worn to the point where good contact is not being made. May a little jiggling could solve the problem temporarily.
09-15-2014, 01:22 PM   #7
New Member




Join Date: Feb 2010
Location: Litiz
Posts: 7
Original Poster
Firstly: Thank you all for the suggestions.

My cleaning method: Alcohol on a q-tip, sqeezed with a paper towel. Gently rub it onto the contacts, and dry with a clean cloth. Then put a clean body cap on for a while. I also do the same to the lens.

My 18-55 does not have an aperture ring (Not a Number is correct). It is the 18-55 that came with the K10D, so it has a metal mount.

The other lenses that I have tried do have aperture rings, but they have been set to A.

I will try removing the battery later tonight, and if that doesn't work I will try to rest the settings.

Again thank you all very much
09-15-2014, 01:28 PM   #8
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 30,584
QuoteOriginally posted by Not a Number Quote
May a little jiggling
What a great technical term that is, we call it shoogling here.

09-15-2014, 03:22 PM   #9
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,158
Here are the symptoms as described with comments (bolded):
  • Gross over-exposure for shots. Lens not stopping down or bad metering.
  • Prompts for focal length with AF lenses. Data pin not functional.
  • Not able to change aperture when SR is turned off. Electronic fault due to dying board or compromised internal connection.
It is that last symptom that is the most dire and the most indicative of a serious problem. You can do a little more testing if you wish, but I don't believe that doing so will provide a work-around or an obvious simple fix.


Steve
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
135mm, camera, length, lens, m42, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lightroom 4.2 Does not Recognize PEF raw file lightbulb Digital Processing, Software, and Printing 19 12-12-2012 08:35 AM
Will Takumar lens work with any 49mm lens hood??? iNicole Pentax SLR Lens Discussion 13 11-08-2012 11:07 AM
Pentax K10d will not auto focus (solved) theunartist Pentax DSLR Discussion 7 04-04-2011 05:48 PM
K7 does not recognize Sigma lens (sometimes) ulrich Pentax DSLR Discussion 15 08-29-2010 05:01 AM
Help K10D Will not Power on !!! daacon Pentax DSLR Discussion 31 12-11-2007 12:35 AM



All times are GMT -7. The time now is 12:13 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top