Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-18-2014, 06:32 AM   #1
New Member




Join Date: Sep 2014
Posts: 4
K 30 integrated flash causes battery depleted error

Hi All,
I've had my K 30 for about a 1.5 years now, and I went to take some family shots the other day using the integrated flash. About 10 seconds later, I get the "Battery Depleted" message and the camera switched itself off.
Using the charger and Li battery that came with the camera, I charged the battery as normal. I thought it was odd that it only took 10 mins to get to full charge. I tried again, and got the same error message followed by an auto-shutdown.
I figured the battery was stuffed, so bought a new one. FYI, I don't have the AA adapter pack, I only have the D-Li 109 batteries. I plugged in the new battery and got the same battery depleted message when I opened up the flash (8-10 seconds later to be more accurate). I tried charging the new battery, and got the same result, so figured I got a dud and ordered a new battery charger since I haven't had a great experience with chargers in the past.
New charger arrives, I put both batteries on the new charger, both came off charge within a few minutes so must have already been full.
I took a bunch of photos without using the flash, no problems. Great!
Then I open up the flash, and again, 8-10 seconds later, I get the battery depleted error.
I'm fast running out of hair to pull, and with baby #2 due in a few months, I really need my flash to work.
Has anyone experienced this issue and resolved it?
Sorry for wall of text but I wanted to make sure I gave as much info as possible.
Seriously am perplexed.
Thanks in advance for any help you can provide.

09-18-2014, 10:42 AM   #2
Site Supporter
K57XR's Avatar

Join Date: Feb 2011
Location: Colorado, USA
Posts: 813
Maybe this thread will help, I hope: https://www.pentaxforums.com/forums/151-pentax-k-30-k-50/228221-battery-depleted.html
09-18-2014, 12:31 PM   #3
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,233
QuoteOriginally posted by K57XR Quote
That thread was specifically related to AA batteries. The problem here is with the D-Li 109 lithium battery. I cannot offer any advice to the OP, though I might ask if the battery charge stays up for a reasonable number of exposures when flash is not used. The "discharged" warning comes up when voltage drops. The battery condition and voltage are recorded in the exif.

If camera is still under warranty, I would pursue the matter directly with Ricoh/Pentax ASAP.


Steve
09-20-2014, 02:50 PM   #4
New Member




Join Date: Sep 2014
Posts: 4
Original Poster
I haven't managed to take enough photos to deplete a battery. The battery works as normal while taking photos without the flash, but as soon as I pop the flash up, I get the error followed by camera shutdown. I close the flash and can continue to take photo after photo after photo.


Steve, I tried access the exif info using the silkypix software but it doesn't show battery condition or voltage. Is there somewhere else I should be looking? The manual didn't help me a great deal.


Thanks

09-21-2014, 12:54 PM   #5
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,233
QuoteOriginally posted by perplexed Quote
Steve, I tried access the exif info using the silkypix software
ExifTool will give the full dump. Google ExifToolGUI for the graphical interface version.


Steve
12-11-2014, 12:15 AM   #6
New Member




Join Date: Sep 2014
Posts: 4
Original Poster
QuoteOriginally posted by stevebrot Quote
ExifTool will give the full dump. Google ExifToolGUI for the graphical interface version.


Steve
Thanks Steve. I've tried and tried but cant get the info you mention. I've dropped the camera off to a local repairer in the hope that they can fix the problem, or at least find the source of the problem. Worst case scenario is I buy a new camera for 2015!
Thanks again for your suggestions and help.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, battery, camera, charge, charger, error, flash, flash causes battery, k30 battery depleted, message, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Autofocus Probem/Depleted Battery Error (K5) slowdive101 Pentax K-5 12 10-05-2014 01:17 AM
K-5 - Mirror doesn't fire, says battery depleted. Eulogy Troubleshooting and Beginner Help 21 09-06-2014 02:02 PM
AA Battery Pack FG on ZX-30: odd error TAGFoto Troubleshooting and Beginner Help 2 03-28-2014 10:27 AM
Battery depleted kosmoejtg Pentax K-30 & K-50 16 11-13-2013 05:06 AM
battery depleted shereen roshana Pentax Compact Cameras 2 11-15-2012 11:47 AM



All times are GMT -7. The time now is 04:24 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top