Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-02-2014, 05:07 AM   #16
New Member




Join Date: Oct 2014
Posts: 5
Original Poster
thanks,

yes i have firmware 1.03, which i re-installed 2 days ago in order to test whether this was the problem.

But nothing changed.

What i will do as next steps:
- try to find a small screw in order to put at the missing screw place in the battery compartment.
- put some contact cleaner
- change battery selections in menu
- buy some other batteries in the market

Then if nothing changes, take it for repair in a Canon shop - i called them and said they would be happy to check it for me.
Then depending on cost, would need to start searching for a new camera!

Thanks

12-04-2014, 11:41 PM   #17
New Member




Join Date: Aug 2013
Posts: 3
K-x Autofocus solution

I've had the same issue as you a couple of times, but it was 100% my fault & was easily fixed.
My problems came from buying second hand vintage lenses & in my keenness to try them out, not checking for dirt on the lens, which got into
the body of the camera through the autofocus screw and stopped it working.

Previous posters have mentioned contact cleaner, but to be more precise, the thing you need is electronic cleaning solvent - isopropyl alcohol Isopropyl Alcohol 400ml | Maplin. Carefully spray a little into the autofocus screw & the MF/AF switch, then wait until the smell of the alcohol has completely gone.

This means the alcohol will have completely evaporated, taking the dirt with it.
After this, the autofocus should be back to normal.

If it still doesn't work and you decide to desert Pentax, I'd buy Nikon rather than Canon!
02-28-2015, 12:36 PM   #18
New Member




Join Date: Aug 2010
Location: San Diego, CA, USA
Posts: 7
I was having the same issues, but there is a work around that works for me. In the Menu, under the C tab, see #10. Set the AF/AE-L button to #1. This allows you to obtain auto focus by pressing the physical AF/AE-L button with your thumb. I have always used it this way because I prefer that to pressing the shutter down half way. But, my wife is now using this camera and she keeps forgetting to do that. Previously, I did have the problem of no auto focus even when using the AF/AE-L button, but I fixed that by cleaning the contacts. The problem now simply appears to be the camera does not focus by pressing the shutter down half way. I can get it to do it sometimes, but that is rare. So, it seems using the AF/AE-L button is the solution until the whole thing just stops working.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, camera, k-x autofocus, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax k-x display not working jersey_m Troubleshooting and Beginner Help 16 09-17-2014 06:24 PM
Autofocus not working lskeens Pentax K-r 2 11-02-2013 08:05 AM
K-X MF AF switch not working viper56 Troubleshooting and Beginner Help 3 06-29-2013 07:09 PM
Grrr...autofocus on k-x not working rachcobb Troubleshooting and Beginner Help 9 01-10-2012 09:29 AM
survey: batteries working/not working with the K-x noou Pentax DSLR Discussion 25 12-03-2009 02:43 PM



All times are GMT -7. The time now is 06:46 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top