Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-01-2014, 12:03 AM   #1
New Member




Join Date: Oct 2014
Posts: 5
K-X autofocus not working

Hello,

i have the camera for about 4,5 years, and now the autofocus is not working.

Is started slowly since for about a week the autofocus was coming and going. But now i dont have at all, i tried to clean whatever i could, tried with two lenses, tried wiithout a lens, but when i turn on the button of AF on the screen it still indicates MF.

So i suppose is something that i cannot solve. I even re-updated the 1.03 update, but with no result.

Would you have any suggestions?

Thanks

10-01-2014, 03:01 AM   #2
Pentaxian
aurele's Avatar

Join Date: Jan 2011
Location: Paris, France
Photos: Albums
Posts: 2,967
Does the motor Does any sound ? or is it ... well, "dead silent" ?
10-01-2014, 04:06 AM   #3
Site Supporter




Join Date: Oct 2006
Location: Dayton, OH
Photos: Gallery
Posts: 4,154
It may be worthwhile spraying the AF/MF button on the body with some contact cleaner. Something could be causing a contact issue with the switch.

Tim
10-01-2014, 04:23 AM   #4
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,927
QuoteOriginally posted by atupdate Quote
It may be worthwhile spraying the AF/MF button on the body with some contact cleaner. Something could be causing a contact issue with the switch.

Tim
+1, I had the same problem and it worked for me. With time there must be an accumulation of some dust /grit, especially on the K-x which is not WR...

10-01-2014, 06:25 AM   #5
Veteran Member
Andi Lo's Avatar

Join Date: Jul 2008
Location: Halifax, Nova Scotia
Posts: 2,925
Make sure than when the dial is on "AF", you can see that the AF gear is protruding out from the mount . Play with the AF/MF switch a bit if it doesnt protrude
10-01-2014, 07:06 AM   #6
New Member




Join Date: Oct 2013
Photos: Gallery
Posts: 10
I had the same problem with my Kx almost 10 months after i bought it new . The problem started the same as with the op , auto focus coming and going, sometimes repeatedly turning it on and off would work, sometimes switching the af/mf multiple times would work. But eventually it gave away .

It was still under warranty, so the local dealer took it in. The y told me the circuit board needed replacement. I specifically asked if it wasn't just the problem with the switch. They said it wasn't. They repaired it and it worked before going AWOL again three months later. Now i just make use of our as a manual focus DSLR
10-01-2014, 11:35 AM   #7
New Member




Join Date: Oct 2014
Posts: 5
Original Poster
Thank you for all replies and help

- The motor does not make any sound
- when i change position of the button, i can see the small extension moving, but no change in software...
- unfortunately this period of time (having twins of 13 months old) we need to have AF.. Not just for taking photos of fast moving kids, but to be able to give the camera to someone else to grab us a photo. With MF, how can you give a DSLR to someone and tell him to focus, and especially the K-X that does not have focus indicator...

I will try the spray and revert!
10-01-2014, 12:01 PM   #8
Veteran Member
Andi Lo's Avatar

Join Date: Jul 2008
Location: Halifax, Nova Scotia
Posts: 2,925
K-x does have focus indicator, but it's a pain to use. When the lens is focused the green hexagon will light up.

I would suggest buying another k-x.

10-01-2014, 12:03 PM   #9
Junior Member




Join Date: Sep 2014
Posts: 29
QuoteOriginally posted by ghufran_ali Quote
I had the same problem with my Kx almost 10 months after i bought it new . The problem started the same as with the op , auto focus coming and going, sometimes repeatedly turning it on and off would work, sometimes switching the af/mf multiple times would work. But eventually it gave away .

It was still under warranty, so the local dealer took it in. The y told me the circuit board needed replacement. I specifically asked if it wasn't just the problem with the switch. They said it wasn't. They repaired it and it worked before going AWOL again three months later. Now i just make use of our as a manual focus DSLR
Not sure about the K-x but in K-m the AF/MF switch is mounted on a tiny circuit board that only has the switch and two wires connected to.

My K-m act exact like that a month ago. I open the front up and checked connectivity of switch, for sure it is comes and go. (AF should be close and MF open) The switch has bad contact. Brave enough, I open the switch to fix it. The contact of switch really just a coil spring between two copper plates which also serve as soldering terminals. Clean the copper plates and re-seat the spring fixed problem.

The switch is about 4 mm x 3 mm in size and 1 mm thick, I have to use microscope to perform the work. A steady hand also very important.

Confirm the switch with debug mode first.
10-01-2014, 08:31 PM   #10
New Member




Join Date: Oct 2014
Posts: 5
Original Poster
To be honest I am thinking of going to a Canon, I am not sure if I will buy a Pentax... for sure NOT another k-X, very unhappy with it.
I just dont accept the fact that after just 4 years such an important feature is broken... Plus the fact that lately it is not showing correctly the battery indicator...
10-01-2014, 11:13 PM   #11
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,927
QuoteOriginally posted by cyprus Quote
To be honest I am thinking of going to a Canon, I am not sure if I will buy a Pentax... for sure NOT another k-X, very unhappy with it.
I just dont accept the fact that after just 4 years such an important feature is broken... Plus the fact that lately it is not showing correctly the battery indicator...
If you think you'll have less problems, especially after 4 years use, with any other brand..... do some research. In the end a camera is just a tool, so whatever you decide, good luck and enjoy your photography
10-02-2014, 12:36 AM   #12
New Member




Join Date: Oct 2014
Posts: 5
Original Poster
QuoteOriginally posted by altopiet Quote
If you think you'll have less problems, especially after 4 years use, with any other brand..... do some research. In the end a camera is just a tool, so whatever you decide, good luck and enjoy your photography
Thanks, so you mean other brands have such problems as well? I don't know many details since this is my first DSLR.

My main problem now is that in Cyprus were i live, we do not have a Pentax service shop - thus the camera needs to be sent abroad etc. But we have a canon repair shop...

Anyway i will try to solve the problem, otherwise in the next week i will start the search for a new camera! I have no idea what is going in the market, or what new models does Pentax have. I just did a search back then for a beginner's DSLR and purchased the K-X.

Just a question about something i noticed today, as you can see from the attachment (the photo is not from my camera) one of the small black screws is missing from my battery compartment - more specific the top left small black screw is missing. Would you think that this might cause the wrong battery indication?
Attached Images
 
10-02-2014, 02:32 AM   #13
Pentaxian
aurele's Avatar

Join Date: Jan 2011
Location: Paris, France
Photos: Albums
Posts: 2,967
i'm more inclined to think that if you never updated the firmware, or you didn't specifically set in the Kx menu what kind of battery you are using, then the problem can come from there.
10-02-2014, 04:25 AM   #14
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,927
QuoteOriginally posted by aurele Quote
i'm more inclined to think that if you never updated the firmware, or you didn't specifically set in the Kx menu what kind of battery you are using, then the problem can come from there.
+1 I remember when I got my K-x, there was a problem with the battery indicator, but that was fixed in a firmware update...
10-02-2014, 04:40 AM   #15
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,927
QuoteOriginally posted by cyprus Quote
Thanks, so you mean other brands have such problems as well? I don't know many details since this is my first DSLR.
Take some time and Google, look for known problems and issues with certain cameras or lenses, I always do that before making a purchase, as there are a lot of the time some teething problems, especially with first batches of cameras, which get sorted out with time. My K-x has about 45K clicks and is still going strong, now relegated to backup body, as I acquired a K-30, now at about 15K clicks, with which I had some mirror box problems that was fixed, and a K-5iis, at 16K clicks with no problem so far...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, camera, k-x autofocus, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax k-x display not working jersey_m Troubleshooting and Beginner Help 16 09-17-2014 06:24 PM
Autofocus not working lskeens Pentax K-r 2 11-02-2013 08:05 AM
K-X MF AF switch not working viper56 Troubleshooting and Beginner Help 3 06-29-2013 07:09 PM
Grrr...autofocus on k-x not working rachcobb Troubleshooting and Beginner Help 9 01-10-2012 09:29 AM
survey: batteries working/not working with the K-x noou Pentax DSLR Discussion 25 12-03-2009 02:43 PM



All times are GMT -7. The time now is 01:36 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top