Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-12-2014, 03:11 PM   #1
New Member




Join Date: Oct 2014
Posts: 3
Can't see through Pentax 645 viewfinder

I just purchased a Pentax 645 through ebay. I have attached my Pentacon 6 lens via an adapter. With the lens cover off, when I look through the viewfinder, all is black. Any opinions why? I can try new batteries but the lcd display does show when the camera is turned on.

10-12-2014, 04:06 PM   #2
Pentaxian




Join Date: Sep 2013
Location: Sydney
Photos: Albums
Posts: 844
Have you put any film in? If you fire the shutter without film, the shutter will lock up. There's a special backing plate for the 645 that will allow you to test fire the shutter, but my advice is to forget about the camera entirely unless film is loaded.

---------- Post added 10-13-14 at 12:19 AM ----------

P.s. I went through this nightmare when I first got my 645. You're probably going to lose the first roll of film (or more accurately, it'll think you're halfway through a roll when you load it, and the first 10 won't come out, but will keep firing until exposure 25, so you will get a roll in total, just not the shots you expect!).

Iirc, when I had the problem I had to take the lens off, and *carefully* bring the mirror down into place by hand. It occasionally locked again over the first couple of rolls, but has been fine ever since. Touch wood, hopefully it's the same problem..,

Don't fire that shutter ever!!! (Unless there is a film in there)
The electronics get confused!

They work great if you stick to that rule (even when firing with the backing plate in, I had problems, so don't bother!)

---------- Post added 10-13-14 at 12:21 AM ----------

P.p.s. Try new batteries anyway. The 645 starts mis behaving if the batteries are low, so it's best to rule that out if you can.
10-13-2014, 02:17 PM   #3
New Member




Join Date: Oct 2014
Posts: 3
Original Poster
Thanks, that solved the problem.

I was able to drop the mirror and (hopefully) won't have much of a problem with it once I start shooting. I also did put in new batteries just to be sure.
I'll also make sure that I only shoot lousy pictures for my first roll of film. That way I won't be disappointed if they don't all show up. Thanks robthebloke for helping.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, film, fire, lens, pentax, pentax help, photography, plate, post, roll, rule, shutter, troubleshooting, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Question Why can't I see images? LaurenOE Site Suggestions and Help 2 04-24-2013 03:35 PM
Error can't see some pictures wisent Site Suggestions and Help 4 03-25-2013 06:27 PM
Macro You can't see me... bluestringer Post Your Photos! 4 10-27-2012 11:48 AM
Can't shoot focused images through viewfinder at f/1.4 mrjamesabels Troubleshooting and Beginner Help 23 03-07-2010 08:02 PM



All times are GMT -7. The time now is 02:29 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top