Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-18-2014, 04:39 PM   #1
New Member




Join Date: Apr 2012
Posts: 2
wireless flash with k-x

I've have problems shooting external flash with my KX and a cowboystudio model NPT-04 FMkio trigger.
Wich is the right channnel setting.?

My flash is DF-383-PANA VIVITAR SERIES 1

I will apreciate any help .Regrads.

10-18-2014, 06:06 PM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,288
Might be easier to help if we knew what kind of problems you are having? Flash not firing? Exposure?

One thing to check is to make sure your shutter speed is less then 1/180th otherwise the flash will not fire. Other than that, more information needed to help.
10-18-2014, 07:23 PM   #3
New Member




Join Date: Apr 2012
Posts: 2
Original Poster
QuoteOriginally posted by jatrax Quote
Might be easier to help if we knew what kind of problems you are having? Flash not firing? Exposure?

One thing to check is to make sure your shutter speed is less then 1/180th otherwise the flash will not fire. Other than that, more information needed to help.
Flash not firing...
10-18-2014, 07:30 PM   #4
Veteran Member
kp0c's Avatar

Join Date: Jan 2010
Location: Montreal
Photos: Gallery
Posts: 721
So, what agout shutter speed?
Just set same setting on the transmitter and receiver and things should work. There should be a test button on your transmitter, if so, does that fire the flash?

10-18-2014, 08:25 PM   #5
Loyal Site Supporter
clackers's Avatar

Join Date: Jul 2013
Location: Melbourne
Photos: Albums
Posts: 7,706
First check the flash is firing when on the hotshoe before trying it off camera ...
10-19-2014, 04:48 PM   #6
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,288
QuoteOriginally posted by Cesar Ruiz Quote
Flash not firing...
1) Put camera in manual.
2) Set shutter speed to something less than 1/180
3) Take a test shot, does the flash fire?

If it does the shutter speed was your issue.
If not:
1) Test with the flash on the camera
2) What settings will the flash fire at?
If none, then maybe the flash is bad,
If yes:
1) make sure the triggers are on the same channel
2) Triggers should have a test button, does that work?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, channel, flash, pentax help, photography, setting, troubleshooting, wireless
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-x and wireless flash triggers CRMassart Pentax DSLR Discussion 9 11-26-2013 04:02 AM
Flash with wireless control for Pentax K-r Francisco Paolillo Visitors' Center 5 11-25-2013 05:13 AM
K-x popup flash AND wireless P-TTL with AF-360 FGZ? runswithsizzers Flashes, Lighting, and Studio 5 07-29-2011 11:21 PM
K-x and wireless flash tbirdas Flashes, Lighting, and Studio 2 11-07-2010 08:37 PM
Basic Pentax K-x, hot-shoe, flash, flash bracket, wireless question MrPetkus Flashes, Lighting, and Studio 5 04-27-2010 10:57 PM



All times are GMT -7. The time now is 10:28 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top