Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-01-2014, 06:56 PM   #1
New Member




Join Date: Nov 2014
Posts: 1
Mode Dial Problem

I just bought a brand new K 50 and I have problems with the Mode Dial. The Auto and Scene modes don't align with the white indicator line. If I set it on Auto, it's still in Movie mode, only changes to Auto if I am half way between Auto and Scene, and changes to Scene when I am just before Scene, if I stop at Scene it shows User1.

Anyone else experienced this? Do you think it's a mechanical/hardware problem?

Thanks

11-01-2014, 07:26 PM - 1 Like   #2
Senior Member




Join Date: Oct 2008
Location: Prince George, British Columbia, Canada.
Posts: 129
Send it back!
11-01-2014, 09:48 PM   #3
Senior Member




Join Date: Sep 2009
Location: Wisconsin
Posts: 144
sounds like it is aligned incorrectly - I would send it in for warranty work, or return it outright
11-01-2014, 10:20 PM   #4
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,189
QuoteOriginally posted by BCtoad Quote
Send it back!
Yes, take it back to the store where you bought it. They should give you a new one off the shelf. Don't bother with warranty if it is that new.


Steve

11-02-2014, 03:11 AM   #5
Pentaxian
flaviopetrone's Avatar

Join Date: Aug 2014
Location: Reggio Emilia
Photos: Albums
Posts: 1,146
I am agree, you should go back to the shop as soon as possible because in this way they should give you back another one. If you start the warranty process, you need to waaaaaiiiit...
11-03-2014, 02:44 AM   #6
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,188
Yup, just ask them to swap it for another one.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, camera, changes, dial, k50, mode, pentax help, photography, scene, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-01 Mode Dial problem PJ1 Pentax K-01 114 09-13-2016 04:19 AM
Anyone else had a problem with the mode dial? rickn Pentax K-01 2 04-10-2013 01:18 AM
K20D Mode Dial Problem ChucK20D Troubleshooting and Beginner Help 6 11-20-2012 07:37 PM
Mode dial problem on K10d Plornt Pentax DSLR Discussion 13 03-16-2011 10:46 PM
k100d mode dial problem song_hm Pentax DSLR Discussion 15 03-14-2011 01:14 AM



All times are GMT -7. The time now is 08:29 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top