Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-03-2014, 12:40 AM   #1
New Member




Join Date: Nov 2014
Posts: 2
K2000 Stopped Working

Have a Pentax K2000 used it on a day shoot without issue and then right in the middle of a shot it stopped working. Battery power was good up to that point. Changed to new batteries anyway, no good. Tested the old ones and they still have power. So I suspect low or no power is not the issue. Camera will not show any signs of life. Checked and cleaned battery contacts, took out and reseated memory card. Even plugged it into my PC, and still no life. Is there a way to reset the camera? Looking for options.

No I don't want to buy a K30. Just want my camera back to life.

11-03-2014, 01:52 AM   #2
Pentaxian
LensBeginner's Avatar

Join Date: Sep 2014
Photos: Albums
Posts: 2,607
If it's not even booting, then I'm afraid there's little you can do apart from bringing it to a service center...
11-06-2014, 09:23 PM   #3
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 6,552
QuoteOriginally posted by house7935 Quote
Have a Pentax K2000 used it on a day shoot without issue and then right in the middle of a shot it stopped working. Battery power was good up to that point. Changed to new batteries anyway, no good. Tested the old ones and they still have power. So I suspect low or no power is not the issue. Camera will not show any signs of life. Checked and cleaned battery contacts, took out and reseated memory card. Even plugged it into my PC, and still no life. Is there a way to reset the camera? Looking for options.

No I don't want to buy a K30. Just want my camera back to life.
Have you tried leaving the camera without any battery inside for a few hours to ensure no latent voltage?
11-08-2014, 09:49 PM   #4
New Member




Join Date: Nov 2014
Posts: 2
Original Poster
Actually I owe my wife a on the fix for this issue. She noticed that there was some white "corrosion" on one of the battery contacts. We have just recently moved from a very dry climate, almost desert, to a very humid one. I cleaned off the battery contact, but still no luck. Took a small jeweler phillips head screw driver and pulled off the contacts. Corrosion was on the bottom of the plates. One minute to clean, one more minute to reinstall and WaaLaa, camera is back in action! So it was a power issue after all. Note to self, keep your battery contacts clean.

11-09-2014, 12:44 AM   #5
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 6,552
QuoteOriginally posted by house7935 Quote
Actually I owe my wife a on the fix for this issue. She noticed that there was some white "corrosion" on one of the battery contacts. We have just recently moved from a very dry climate, almost desert, to a very humid one. I cleaned off the battery contact, but still no luck. Took a small jeweler phillips head screw driver and pulled off the contacts. Corrosion was on the bottom of the plates. One minute to clean, one more minute to reinstall and WaaLaa, camera is back in action! So it was a power issue after all. Note to self, keep your battery contacts clean.
You must be super pleased with the cheap fix!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, issue, k2000, life, pentax help, photography, power, stopped working, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
anti-shake update stopped working krema Pentax Q 8 11-11-2014 05:12 PM
Panic! my pentax stopped working Austeja Visitors' Center 2 10-08-2013 05:47 AM
Update has stopped camera working MFW Pentax K-30 & K-50 7 06-07-2013 08:38 AM
My Pentax K2000 has stopped working Mark Archbold Visitors' Center 3 05-23-2013 09:11 AM
Sound stopped working MRunkle Pentax K-5 3 05-15-2013 12:14 PM



All times are GMT -7. The time now is 02:02 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top