Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-25-2014, 12:10 AM   #1
New Member




Join Date: Feb 2012
Posts: 8
K3 flash trigger problem

Hi All

I hope you all can help a newish K3 user! I have had it for a while and have successfully used it with a Hahnl trigger to set of studio lights and remote strobes. I have also used us successfully with the photographic club studio trigger. Last night we had a studio evening at the club and the camera will trigger a hot shoe mounted flash but will not trigger via the hahnl or club trigger.

Camera set to manual flash set to on and the manual button on both triggers will fire the lights? Flash symbol is visible in the top panel when the flash is mounted but not when the trigger is mounted. Back into settings and switch flash back on but still no joy. All the components work so assume there is a setting I've overlooked

Any advice gratefully received!!

Thanks in advance

Andre

11-25-2014, 05:08 AM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,292
Camera shutter speed at 1/180 or less?

Try it in x mode as a test.
11-25-2014, 06:53 AM   #3
New Member




Join Date: Feb 2012
Posts: 8
Original Poster
Hi Jatrax

Thanks so much for the advice sir!

Tried in x mode and shutter speed was less that 180th. Set up with flash on hot shoe and it fires, metering is good, without changing settings other than switch off and then back on to replace the flash with the trigger and the flash symbol goes from the top screen and no flash via trigger. Slide the flash back on and the symbol reappears and the flash fires!!

André
11-25-2014, 11:08 AM   #4
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,292
I'm not familiar with that trigger so anything I have to say is just generic. Since the trigger fires the flash using the test button it would seem the problem is the interface between the trigger and camera. So I would look for a way to test that.

Does the trigger have a hot shoe pass through so you can mount a flash on top? If so try that to see if the camera can see the flash through the trigger.

Is there a lock wheel or lever on the trigger? Sometimes if that is partially engaged the trigger will not seat fully onto the camera hot shoe and the contacts are misaligned just enough to not make contact.

Take a look at the contacts on both the camera and trigger to check for anything that might be bent or damaged.

Try a different trigger if one is available.

I'm not sure if the flash symbol is significant or not, I do not think it lights up when I put my trigger on. I think it only lights up if it finds a P-TTL flash. Not 100% sure on that though.

11-27-2014, 01:38 PM   #5
New Member




Join Date: Feb 2012
Posts: 8
Original Poster
Jatrax thanks for the advice, can't put a flash on top of the trigger so sadly can't try that.

Gave the contacts a clean with IPA and trigger now works on aperture priority and on X but not on M. Didn't try on anything else, will keep experimenting and see where I get to
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, club, flash, k3, lights, pentax help, photography, studio, trigger, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3 popup flash as trigger geordieman Pentax DSLR Discussion 9 10-31-2014 02:41 AM
Softbox/Trigger problem degnann Flashes, Lighting, and Studio 10 09-24-2014 04:19 AM
Aftermarket flash option, Q does not trigger my one-pt flash MegaPower Pentax Q 10 03-04-2013 08:35 PM
Remote flash trigger problem stjohndunn Pentax K-5 2 01-04-2011 07:39 PM
Wireless trigger problem with Pentax 540 flash m42geo Flashes, Lighting, and Studio 7 07-03-2009 02:08 AM



All times are GMT -7. The time now is 02:19 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top