Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-27-2014, 10:21 AM   #1
Site Supporter




Join Date: May 2014
Location: Minnesota
Photos: Gallery
Posts: 1,369
Problems with Pentax Utility 4

When I first got my K-5 II, I downloaded the Pentax Utility Software(SILKYPIX) the camera came with no problems. Compared to other photo editing software, it was a little slow, but there were some features I liked about it. Recently my computer got hit with some type of virus that caused it not to recognize some peripherals and photo editing packages including Pentax Utility 4. I removed the virus from my computer and reinstalled each and every one of these packages including Picasa, My scanner, Photoshop elements, SilverFast etc.


They are now all working fine except for Pentax Utility 4. I tried Uninstalling and Reinstalling this package and everything seems to go well until I get a popup box asking me to Login ? I don't remember this software ever asking me to login so I'm scratching my head. This is a s far as I can get with this software. I tried all kinds of combination User ID/Passwords but none of them work ? Finally I have to call Task Manager to get rid of the login pop-up box. Any ideas ?

11-27-2014, 10:32 AM   #2
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 2,655
QuoteOriginally posted by hjoseph7 Quote
When I first got my K-5 II, I downloaded the Pentax Utility Software(SILKYPIX) the camera came with no problems. Compared to other photo editing software, it was a little slow, but there were some features I liked about it. Recently my computer got hit with some type of virus that caused it not to recognize some peripherals and photo editing packages including Pentax Utility 4. I removed the virus from my computer and reinstalled each and every one of these packages including Picasa, My scanner, Photoshop elements, SilverFast etc.


They are now all working fine except for Pentax Utility 4. I tried Uninstalling and Reinstalling this package and everything seems to go well until I get a popup box asking me to Login ? I don't remember this software ever asking me to login so I'm scratching my head. This is a s far as I can get with this software. I tried all kinds of combination User ID/Passwords but none of them work ? Finally I have to call Task Manager to get rid of the login pop-up box. Any ideas ?
This is puzzling. You should not have to log in unless they want you to register which I do not remember happening. Do a full uninstall and then TRY to check the registry to see if PU4 left some flags behind. If you have McAfee run the clean function.
11-27-2014, 12:22 PM   #3
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 4,260
It shouldn't be asking for credentials unless it needs admin rights to run on your login or it needs to attach files on a networked or shared drive.

I would suspect you still have a virus or malware on your system. Did you clean the virus on your own or did you seek assistance from a site like dslreports.com or majorgeeks or the like? If you did it on your own I would suggest running a least three different virus scanners especially those that will boot into Linux to run the scan.

If you are absolutely certain your system is clean perhaps try running (on Windows) the PDCU 4 as an administrator.
11-27-2014, 01:34 PM   #4
Site Supporter




Join Date: May 2014
Location: Minnesota
Photos: Gallery
Posts: 1,369
Original Poster
QuoteOriginally posted by Not a Number Quote
It shouldn't be asking for credentials unless it needs admin rights to run on your login or it needs to attach files on a networked or shared drive.

I would suspect you still have a virus or malware on your system. Did you clean the virus on your own or did you seek assistance from a site like dslreports.com or majorgeeks or the like? If you did it on your own I would suggest running a least three different virus scanners especially those that will boot into Linux to run the scan.

If you are absolutely certain your system is clean perhaps try running (on Windows) the PDCU 4 as an administrator.



I just ran a major scan by majorgeeks website(thanks) and there doesn't seem to be any problems with viruses. I tried running the program as an Administrator, checked the compatibility under other operating systems, tried to open a RAW file with the program. Nothing seems to work. If I hit the OK button on the Login box I get a message stating "unknown Format for file PTXUTL.mdb" ? Luckily I can still use Lightroom and Photoshop Elements which are much faster to open and edit my images but it sucks since I paid for the Pentax Utility. Contacting Pentax is a waste of time even if I could because they only work during normal business hours I can see the look on my bosses face while trying to solve an issue like this on the job.


Last edited by hjoseph7; 11-27-2014 at 08:12 PM.
11-27-2014, 01:51 PM - 1 Like   #5
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 4,260
QuoteOriginally posted by hjoseph7 Quote
I get a message stating "unknown Format for file PTXUTL.mdb" ?
Locate and delete this file. It should be down in the Users files on Win7+ or down in Documents and Settings on XP. PDCU 4 will recreate the file on startup. It contains flags and stuff set on images. As I recall there is a bug if you set some stuff you can't get back in until you delete the file.
11-27-2014, 01:53 PM   #6
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 2,655
QuoteOriginally posted by Not a Number Quote
Locate and delete this file. It should be down in the Users files on Win7+ or down in Documents and Settings on XP. PDCU 4 will recreate the file on startup. It contains flags and stuff set on images. As I recall there is a bug if you set some stuff you can't get back in until you delete the file.
This sounds solid. OP please try this ad let us know if it works.
11-27-2014, 07:34 PM   #7
Site Supporter




Join Date: May 2014
Location: Minnesota
Photos: Gallery
Posts: 1,369
Original Poster
QuoteOriginally posted by not a number Quote
locate and delete this file. It should be down in the users files on win7+ or down in documents and settings on xp. Pdcu 4 will recreate the file on startup. It contains flags and stuff set on images. As i recall there is a bug if you set some stuff you can't get back in until you delete the file.


That worked (halleluja) or however you spell it ! Thank you !

Last edited by hjoseph7; 11-27-2014 at 07:49 PM.
11-27-2014, 08:12 PM   #8
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 2,655
QuoteOriginally posted by hjoseph7 Quote
That worked (halleluja) or however you spell it ! Thank you !
Congratulation!

11-28-2014, 01:16 AM   #9
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 4,260
QuoteOriginally posted by hjoseph7 Quote
That worked (halleluja) or however you spell it ! Thank you !
Excellent! Happy Post Processing!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
box, camera, computer, login, pentax, pentax help, pentax utility, photo, photography, software, troubleshooting, utility, virus
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Digital Camera Utility 4 with K-7 Mjason Troubleshooting and Beginner Help 2 07-17-2014 01:41 AM
Problems with Digital Camera Utility 5 EagleEye Digital Processing, Software, and Printing 3 02-13-2014 09:48 PM
Pentax Digital Camera Utility 4 problems slr_neophyte Troubleshooting and Beginner Help 8 05-08-2013 01:55 AM
K-X and Pentax Utility 4 Problems Lucas Pentax DSLR Discussion 10 06-26-2010 07:06 AM
Pentax Digital Camera Utility 4 Install Problems MacPentax Digital Processing, Software, and Printing 4 09-26-2009 10:56 PM



All times are GMT -7. The time now is 03:13 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top